Openvpn RoadWarrior doesn't work

Hello, I installed nethserver on vps ovh, all smooth, I need openvpn, so I downloaded and installed openvpn RoadWarrior, certificate only, so I created the client, download the certificate to the mobile phone, it connects for a moment but does not acquire the public ip of the my vps…also tried from windows same behavior. Can you help me thanks

Hi Fulvio,
this community speaks… English. Even though my nickname, I am italian and I read perfeclty your post. However… I suggest you to write in English for wider support and attention.

Back to basics: you installed NethServer on OVH, wonderful. How many network cards your configuration have? Is there at least one network cards on GREEN zone and one on RED zone?

okay sorry, I will write in English, however I have configured only one network green

AFAIK you should have at least two zones/network card configured for have VPN working, in NethServer.
I don’t remember if it’s reported here or into wiki some procedure for create a dummy interface for assign Green Zone and change the current adapter of OVH into a RED one.

1 Like

As @pike pointed out the procedure is described in the wiki:


perfect @dnutan and thanks, I followed the precious guide you indicated, now openvpn connects correctly, but the public ip does not become that of the vps ovh … for openvpn I used certificate mode, routed, network and netmask

i did it i needed to flag “Hijack client traffic through vpn” nethserver is fascinating now i will try port forward…