Open Nextcloud and webservices for external access

NethServer Version: NethServer 7.8.2003
Module: your_module

Hi everyone, recently i have found nethserver and try to use him on my dell r620 server (i have other with windows server but i really want to start using linux), i just installed nextcloud and he runs fine but i want to open for external access and i don’t know how open the doors 80,443 (the router ports are open, but i think the nethserver is blocking).

Can anyone help me?

Ps : im a really newbie on linux.

Best Regards

Hi @diego_rodrigues,
first welcome to the community.
What is your network configuration? At a green interface it shouldn’t be firewalled, if you have connected it with a red interface to the router you have to install firewall at the software center, then you can configure portforwardings and rules at the gui.

Did you do a portforwarding at your router?

Thanks for your reply Michael, i have just one green interface on my network…i do the dmz and portforwarding but i still got no external acess

NethServer network interface points to a gateway?
The external access is done by the public IP or by a domain name?

thanks for reply marc, i just have set one fixed ip adress for the server (dont change nothing else)…on the future i want to connect to a domain name but right now i just want do make acessible from external network

On Nethserver port 80 and 443 for webserver (httpd service) are open by default. You can check it from the service list.

When you use your public IP address (or https://publicip/nextcloud) to access the server from an external network (for instance, from a smartphone Internet connection with Wi-Fi disabled), what do you get?

Im getting ERR_CONNECTION_TIMED_OUT anytime i try to acess

So it seems the router cannot be reached from outside (and ping to the public IP does not resolve?)
Sorry to ask, but are you trying with the public IP address, right? (not the private IP

No problem Marc, yes im using my public ip ! i tried use dmz as well but have no success.

i will try contact with my isp to check if the router is really opened.

Thanks for the support guys.

Best Regards.

progress has been made on the matter, I am having the same difficulty ?

Hi @zepepa

Why reopen a long dead, settled post - this just creates a “zombie”…

Not quite the same difficulty, this guy had a provider issue not allowing access from the internet.
You only have a .lan problem with SSL…

My 2 cents

I wanted to change to the domain.tld as per your guidance Andy.
But I noticed that port 443 and 80 are blocked on the modem for external access, the way I believe will be to change the port on nextcloud.
Sorry to revive the subject

Hi @zepepa

Drop me a PM (Click on my picture top left of any post, then Message in the top right of the box which appears…

We’re hijacking an old post at present, as it is…

My 2 cents

1 Like