ONLYOFFICE print problem

Nethserver 7.9
Module: Nextcloud 20.0.10 + Onlyoffice 6.3.0

Hi Guy, sorry for my english…
I have a problem with onlyoffice prints.
I put screenshots that explain the problem perfectly.
I created a xls file:

Than I printed this file and all OK

After this test, I crated other doc file:

When I tried print, i had this problem.

Does anyone know this problem?
TK

@mrmarkuz Can you help here?

1 Like

I’ve no idea. There was a similar problem in the past but should be fixed long ago:

In fact I have read and see the versions are not the same and it has been a long time.
However, I used the Calibri font.
TK

Anyone else has this problem? :worried:

What if you export the document as PDF, is there the same error regarding the printed table?

EDIT:

I updated to Onlyoffice 6.3.1 and at least the print preview worked:

How did you set the font to Calibri? I only get Arial in the fonts dropdown…

2 Likes

Ciao Markuz.
I’ll test export and the upgrade. I’ll tell you later.
TK

I exported test.docx in test.pdf. The same problem

I loged in whith Admin end in applications there is this upgrade.
Why 6.3.1?

I tested font ARIAL. the same problem.

Maybe it solves the font print issue, see release notes.

OK, so it seems not related to the fonts…

I restored the Onlyoffice fonts by running the following script, maybe it helps in your case too:

/usr/bin/documentserver-generate-allfonts.sh

(Source)

Which browser do you use? Did you already try another one?

3 Likes

:1st_place_medal: :2nd_place_medal: :3rd_place_medal:
Your command, solves the problem.
TK

2 Likes

Hi everyone,
I’have the same issue Nextcloud 23.0.3 + OnlyOffice 7.3.2, but I I’m not able to execute the command /usr/bin/documentserver-generate-allfonts.sh
I have Cpanel but I don’t know how to proceed.
Please someone can help me?
Thank You so much for attention
Warm regards
Ale

How do you have version 7.3.2
this should be the nc integration
The only Office module has version 6.4.2.

Did you install it using onlyoffice repo, or waht it from github

Also, on github, the highest release is 7.0.1 Releases · ONLYOFFICE/DocumentServer (github.com)

whats your actual server version

Hi Martin,
thank You for Your reply.
I installed Onlyoffice with nextcloud simply adding the app in the settings.
I actually use Community Document Server 0.1.12
That’s all I have
:frowning:
Regards
Ale

P.s. Sorry I just noticed that this forum is dedicated for nethserver; I actually work on an hosted server (I suppose centos).

Therefore maybe you should ask into OnlyOffice/Nextcloud community? :wink:
If you find any nice answer, maybe you could still report it there :slight_smile:
Please, keep us posted.

(NethServer is CentOS based but has some different… gears under the hood for configuring services/daemons. NethServer could be also installed on hosted servers too, it also provides a “web console” feature, for using “like SSH” if your hosting service do not provide that)