Onlyoffice certificate problem

I have a problem…
I installed Onlyoffice with Markuz guide line, but the document server work well only in Lan, from Wan I receive this error:

I have a valid let’s for “” but the Server FQDN is “”
I configured alias in nethserver configuration:

if i change configuration and change name (neth to oplfar and viceverse) with this command:

“config setprop fw_onlyoffice host DOMAIN.TLD”

the problem remains.
What I wrong?


Hi @roberto.schiano

You probably need to renew your LetsEncrypt, with your Nethservers FQDN inside.
And that name must be entered in your external DNS, otherwise LetsEncrypt won’t accept it, nor will NextCloud/OnlyOffice work outside your Network…

My 2 cents

1 Like

You also need to execute

signal-event nethserver-onlyoffice-update

after setting a domain to apply the configuration.


Hi, Andy,
Obviously that’s a solution, I don’t have a DNS registered for However the registered DNS “” works correctly for the Server manager, for Nethvoice and also Nextcloud and the server always has the FQDN (


Hi M
Yes, I did.
every time that i changed the configuration, I did.
The problem is: can I use a different DNS name than the FQDN? For other services it works fine.

Yes, by setting the host you can use a different name.
Can you access onlyoffice at ?
I recommend to set a public DNS entry and setup a valid certificate to be able to use Onlyoffice outside of your LAN without issues.
If that’s not possible at all, you can disable the certificate check, see onlyoffice [NethServer Wiki]

1 Like



Which onlyoffice documentserver version did you install?

Do you get an error message in the Nextcloud onlyoffice app settings when you click “Save” ?

1 Like

Documenti server ver. From tour repository.
No. When push “save” all ok.

Hm, maybe it’s not working without valid cert anymore. I need to check…

Did you already try the troubleshooting steps?

1 Like

Hi markuz,
I tried everything. Installation, reinstallation, yes or not certificate, recreate database…
Before Onlyoffice, I had also tried Collabora but without success.
Could it be that the two installations don’t go together? However, before installing onlyoffice I uninstalled Collabora.

If I want to uninstall everything and then start from 0 with other version?
But thinking about it, what I say doesn’t make sense…
In LAN everything works well.
Boh… I don’t know…

Did you uninstall the Nextcloud collabora app (Nextcloud Office) too?

Onlyoffice needs to be reachable from public, just internal DNS doesn’t work.

I started from 0 and reinstalled everything. FQDN server (opllfar), DNS pubblico (neth)
There is a valid let’s certificate
Port 8082 and Onlyoffice aren’tt reachable from internet, but other everything work well.
In LAN using public DNS, Onlyoffice and port 8082 works well…
There aren’t Nextcloud Office or Collabora.
From internet DNS “neth” work well for all except for OnlyOffice.
Sorry, but I can’t do more than that. Do you need some logs or something else?

Onlyoffice needs to be reachable from internet to work with public clients.

Very clear…
Since everything else is working something went wrong with the installation. but what…? work well work well work well


is nethserver behind another firewall/router? (just saying it for the 8082 port)

1 Like

no, there is only one nethserver. Is olso nethsecurity.


Let’s check the config:

config show fw_onlyoffice

Which error do you get when you want to reach Onlyoffice at port 8082 from internet?

Are there errors in the logfiles in /var/log/onlyoffice/documentserver/docservice/?

Please also check that the app documentserver_community is not installed. It’s the Nextcloud internal documentserver and not needed.

1 Like


  1. when I tray to

  1. when type “config show fw_onlyoffice”

Schermata del 2023-02-09 12-36-34

  1. err.log is empty and in out.log there is:

[2023-02-09T05:29:14.547] [WARN] nodeJS - Express server starting…

[2023-02-09T05:29:14.549] [WARN] nodeJS - Failed to subscribe to plugin folder updates. When changing the list of plugins, you must restart the server. File system | Node.js v19.6.0 Documentation

[2023-02-09T05:29:14.695] [WARN] nodeJS - Express server listening on port 48000 in production-linux mode. Version: 7.1.1. Build: 23

  1. Installed app:
    Schermata del 2023-02-09 13-08-50

Schermata del 2023-02-09 13-08-29

Schermata del 2023-02-09 13-05-59

In your configuration you have the properties TCPPort and TCPPorts which could be an issue.
Please delete the TCPPorts property:

config delprop fw_onlyoffice TCPPorts

Apply the config:

signal-event nethserver-onlyoffice-update

Hopefully Onlyoffice is now reachable from WAN.

1 Like