OnlyOffice bad gateway

Having some issues with OnlyOffice on a clean install where https://fqdn:8082 just brings up the “502 Bad Gateway” message and the /var/log/onlyoffice/documentserver/nginx.error.log reports:

"*1 connect() failed (111: Connection refused) while connecting to upstream, client: , server: , request: “GET /welcome/ HTTP/1.1”, upstream: “”, host: “”

On a clean install, I added NextCloud and WebTop; then the OnlyOffice module as per @mrmarkuz how to:

On the above failure, I tried reinstalling OnlyOffice 5.5.1, same result;
I removed OnlyOffice and NextCloud and tried reinstalling just OnlyOffice, same result.

Any assist as to where to look next would be welcome. Thanks.

NethServer Version: NethServer release 7.7.1908 (final)
Module: nethserver-onlyoffice

Please check if the services are running:

supervisorctl status

Seems you already had a similar problem:

Older solution but maybe again some permission problem:

Thanks for the speedy response Markus. Result:

supervisorctl status
ds:converter RUNNING pid 29413, uptime 0:45:57
ds:docservice RUNNING pid 29412, uptime 0:45:57
ds:metrics RUNNING pid 29410, uptime 0:45:57
ds:spellchecker RUNNING pid 29411, uptime 0:45:57

I’ve restarted that - no change;
I tried the permissions setting; there wasn’t an onlyoffice user only group, so I added the user manually;
restarted and still no change.

That other issue you referred to with WebTop was a 403 error and did try running through those fixes. Still at a loss :frowning:

I am going to try to reproduce on a VM…


I found same error on one of my servers but it’s working on this server.

Thanks Markus. It’s a standalone server but I didn’t see your connection hit it so I think it was a country block on the external firewall. I have turned that off now.