Onlyoffice 7.3 invalid token error

Hi, i have same problem
i just verify secret key and is set correct in Nextcloud Onlyoffice admin.
i have Nextcloud 27
i installed onlyoffice 7.3 from you notes
what can I do?


please make a

signal-event nethserver-onlyoffice-update



1 Like

yes already done many times, but I always get token error

Did you install nethserver-onlyoffice 0.0.3 as explained in the quick install section in the wiki?

yum -y install

Let’s check if the configured token in the settings is the right one…

Get token secret:

cat /var/lib/nethserver/secrets/onlyoffice

Get onlyoffice configuration:

occ config:app:get onlyoffice jwt_secret

The result of both commands should be the same.

1 Like

I followed steps in : onlyoffice [NethServer Wiki]

yum -y install
yum -y install Download msttcore-fonts-installer-2.6-1.noarch.rpm (mscorefonts2)
yum -y install
yum -y install

signal-event nethserver-onlyoffice-update

then token secret in /var/lib/nethserver/secrets/onlyoffice is same in nextcloud admin settings
and if i try https://namerver:8082 in browser is ok


I’ll try to reproduce it on a test machine…

So you’re using OnlyOffice 7.4.1 now, not 7.3?


@Gian I can’t reproduce the token error but there’s another issue with an nginx variable regarding version 7.4.1. I need to update the module.
As a workaround you can downgrade to 7.4.0:

yum -y downgrade

Maybe it also helps to restart the document service:

systemctl restart ds-docservice


To use 7.4.1 you need to update nethserver-onlyoffice:

yum install -y

Maybe there’s an invalid character in the token so please edit /var/lib/nethserver/secrets/onlyoffice, execute

signal-event nethserver-onlyoffice-update

and check if it’s working without special characters.


hi thanks for the support …
Today is a nightmare
I’m not good with command line…
my local test server crashed… several tests then nextcloud doesn’t work anymore, onlyoffice error.
I have to start again with a fresh server.

the client company’s nethserver has onlyoffice installed. the key is the same as shown, but when I open a document, the document server does not respond…
Nextcloud 27.0.1 - document server v7.4.1

  • now when I try to open a file from webtop a blank page appears and after timeout the server was not found
  • from administration settings in nextcloud it gives me this error

I had the same error.
Please try following command to restart the service:

systemctl restart ds-docservice


one thing …
on my test machine, before resetting, I tried deleting document server v7.x.x and installing an old v6.2 version that I use and it works. but there is still a token problem. how do I delete this token since v6.2 doesn’t use it? Strange, not everything is removed during uninstallation…

I don’t recommend to install an old version, instead we should find a way to make the new version work.

If you really want the old version, you could delete /var/lib/nethserver/secrets/onlyoffice. It will be recreated during installation when needed.
Maybe you also need an older nethserver-onlyoffice package like nethserver-onlyoffice-0.0.2-1…

Usually these files are no problem but the postgresql database is kept too for instance which could lead to issues.

1 Like

hi, after many tests, I am in a stable situation. I installed Document Server V.7.4.0-163 and Onlyoffice 0.0.3-2. Now in Nextcloud administration settings I don’t have bad gateway 502 errors and it works. I try to open documents in nextcloud and they open with onlyoffice.

if I try to open the same files from webtop I get the token problem

There’s an Issue regarding Webtop and Onlyoffice >= 7.1:

1 Like

Thank you!
I read the post, but if I downgrade to version 7.01, then webtop run and nextcloud doesn’t work?
do I leave nethserver-onlyoffice-0.0.3-2.ns7.noarch.rpm ?
I’m afraid this won’t be resolved…
there’s no guideline to have a stable working installed version…

You’re welcome.

Webtop didn’t work in my tests even with the old 7.0.1 version.
Installing old versions isn’t a good idea anyway.
I’m sorry, best way for now would be to use a recent onlyoffice and edit documents from Nextcloud.
I’m going to recheck the nethserver-onlyoffice Webtop integration…

1 Like

Thank you for your very important work.
having a stable situation where nethserver mail with webtop and nextcloud work with onlyoffice is very important to fight Microsoft’s dominance with 365 and exchange.
having an open source solution to propose is a valid alternative.
It doesn’t matter if you have the latest version of onlyoffice, you just need a working version in both.
I’ll tell you… I have an old version onlyoffice 6.xx on nethserver that works with both webtop and nextcloud. I await your news
Thank you