Only root can edit or make crontab for user (edited tittle)

Hi,
starting ReleaseCandidate2, I read that I can logon to NS shell using user, instead of user@domain.
Nice, shorter commands are better commands.
However, I seem to see that those are not quite the same, since I noticed something strange with crontab:

root@helium:~> $ crontab -u rolf -l
no crontab for rolf
root@helium:~> $ crontab -u rolf@mydomain -l

0,15,30,45 * * * * /home/rolf/scripts/temp_monitor.sh # 1>/dev/null
1,16,31,46 * * * * /home/rolf/scripts/make_graph.sh # >/dev/null 2>&1
50 23 * * * /home/rolf/scripts/archive_graph.sh # >/dev/null 2>&1
6 13 * * * /home/rolf/scripts/twitter_uptime 1>/dev/null

User rolf has no crontab, user rolf@mydomain does.
I thought those should be the same…?
Bug?
Addition: It’s even stranger:
when logging on as rolf, I see no crontab
when logging on as rolf@mydomain, I see no crontab
when logging on as root, I do see a crontab for rolf@mydomain
when logging on as root, I do not see a crontab for rolf

4 Likes

Yes it’s a bug, but of course we could find a fix!

Does crontab command allow reading the user name from the environment?

Did you set crown.allow or cron.deny?

I’d go by always using the long user name form…

1 Like

I have only ever issued the commands crontab -e and crontab -l.
No settings or config changed since fresh install.

If neither of these files exists, only the super user will be allowed to use this command

https://linux.die.net/man/1/crontab

I don’t know if that manpage applies to centos too, but it would explain why only root can set the crontab to rolf@mydomain.

IIUC the numeric user id maps to the long user name format. This could explain why root cannot set rolf (short user name) crontab.

sorry, didn’t follow up on this one.
On my NS, there is an empty file cron.deny. (didn’t make it myself) Meaning all users should be allowed to use cron.
That’s consistent with the error when removing this file: then user rolf gets a message "you’re not allowed to use cron"
So, cron.deny or cron.allow isn’t the cause of this behaviour…
(jobs are actually run as user rolf, so that’s OK as well. It’s just about editing the crontab as user directly).
Is this reproducible by others?