Only Office "An error has occurred while opening the file"

Ok guys I need some help I updated Next-cloud by uninstalling and reinstalling Nextcloud I have also reinstalled Onlyoffice using the wiki afterwards I cant get only office to open any files I keep getting “An error has occurred while opening the file” I can connect to the only office server via https://xxxx.xom:8082 when I press save in the only office setup saves with no issues. I read some were if If you run # su - onlyoffice -s /bin/sh -c “psql -c ‘truncate table task_result’” it will fix this error however when I run the command I get “su: user onlyoffice does not exist” I also had to re setup my external smb storage in next cloud after re-instal any help with this will be greatly appreciated.

I can’t reproduce, which version of Onlyoffice do you use?

[root@server2 ~]# rpm -q onlyoffice-documentserver

This command should work for truncating the table:

su - postgres -c "psql -c 'truncate table task_result' onlyoffice"

su - postgres -c “psql -c ‘truncate table task_result’ onlyoffice” that fixed the “Error Loading File” now I’m getting " Fonts are not loaded" error on some documents.

Screen Shot 2021-10-27 at 3.08.11 PM

Screen Shot 2021-10-27 at 11.15.37 AM

Thanks again Markus for all your help.


I can’t reproduce the error, could you share a document where the fonts are not loading?

Did you install additional fonts?

yum -y install

Maybe try to regenerate the fonts: fixed it thank you Markus

1 Like