Ntopng and DPI log warnings

ntop
ndpi
v7

(Juan Carlos Fernandez) #1

NethServer Version: 7.5.1804 (final)
Module: ndpi,ntopng

Every time I start my NS 7.5, I see this on logs:

Jul 18 12:47:36 heimdall.dcserver.local ntopng[1174]: [NtopPro.cpp:300] WARNING: [LICENSE] Invalid or missing license
Jul 18 12:47:36 heimdall.dcserver.local ntopng[1174]: [NtopPro.cpp:317] WARNING: [LICENSE] ntopng will now run in enterprise edition for 10 minutes
Jul 18 12:47:36 heimdall.dcserver.local ntopng[1174]: [NtopPro.cpp:319] WARNING: [LICENSE] before returning to community mode
Jul 18 12:47:36 heimdall.dcserver.local ntopng[1174]: [NtopPro.cpp:321] WARNING: [LICENSE] You can buy a permanent license at http://shop.ntop.org
Jul 18 12:47:36 heimdall.dcserver.local ntopng[1174]: [NtopPro.cpp:323] WARNING: [LICENSE] or run ntopng in community mode starting
Jul 18 12:47:36 heimdall.dcserver.local ntopng[1174]: [NtopPro.cpp:324] WARNING: [LICENSE] ntopng --community
Jul 18 12:47:38 heimdall.dcserver.local kernel: xt_ndpi: loading out-of-tree module taints kernel.
Jul 18 12:47:42 heimdall.dcserver.local ntopng[1174]: [ViewInterface.cpp:57] WARNING: Skipping view sub-interface  eth0: not found
Jul 18 12:47:46 heimdall.dcserver.local ntopng[1174]: [NetworkInterface.cpp:1920] WARNING: If you have TSO/GRO enabled, please disable it
Jul 18 12:47:46 heimdall.dcserver.local ntopng[1174]: [NetworkInterface.cpp:1922] WARNING: Use sudo ethtool -K eth0 gro off gso off tso off
Jul 18 12:48:02 heimdall.dcserver.local chronyd[710]: System clock wrong by -14399.770046 seconds, adjustment started
Jul 18 08:48:02 heimdall.dcserver.local chronyd[710]: System clock was stepped by -14399.770046 seconds
Jul 18 09:00:10 heimdall.dcserver.local ntopng[1174]: [NetworkDiscovery.cpp:215] ERROR: MDNS Send error [1/Operation not permitted]
Jul 18 09:00:13 heimdall.dcserver.local ntopng[1174]: [NetworkDiscovery.cpp:215] ERROR: MDNS Send error [1/Operation not permitted]
Jul 18 09:00:17 heimdall.dcserver.local ntopng[1174]: [NetworkDiscovery.cpp:215] ERROR: MDNS Send error [1/Operation not permitted]
Jul 18 09:00:22 heimdall.dcserver.local ntopng[1174]: [NetworkDiscovery.cpp:494] ERROR: Send error [1/Operation not permitted]
Jul 18 09:01:32 heimdall.dcserver.local ntopng[1174]: [NetworkInterface.cpp:1920] WARNING: If you have TSO/GRO enabled, please disable it
Jul 18 09:01:32 heimdall.dcserver.local ntopng[1174]: [NetworkInterface.cpp:1922] WARNING: Use sudo ethtool -K eth1 gro off gso off tso off

I’m concerned mainly on the ntopng warning that’s telling me to disable TSO/GRO by typing this:

ethtool -K eth1 gro off gso off tso off

Also, there is several errors regarding MDNS and ntopng

Please help


(Markus Neuberger) #2

Which kernel are you running? Maybe a reboot is missing to run the newest one.

uname -a


(Juan Carlos Fernandez) #3

Hello @mrmarkuz, as usual thanks for helping me out:

uname -a
Linux heimdall.dcserver.local 3.10.0-862.6.3.el7.x86_64 #1 SMP Tue Jun 26 16:32:21 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

(Markus Neuberger) #4

I have same log entries when rebooting.

I found that we can ignore this warning with modern NICs:


(Juan Carlos Fernandez) #5

Thanks @mrmarkuz, but what about the MDNS error on the log entry?

Jul 18 12:00:12 heimdall.dcserver.local ntopng[1174]: [NetworkDiscovery.cpp:215] ERROR: MDNS Send error [1/Operation not permitted]
Jul 18 12:00:15 heimdall.dcserver.local ntopng[1174]: [NetworkDiscovery.cpp:215] ERROR: MDNS Send error [1/Operation not permitted]
Jul 18 12:00:17 heimdall.dcserver.local ntopng[1174]: [NetworkDiscovery.cpp:215] ERROR: MDNS Send error [1/Operation not permitted]
Jul 18 12:00:24 heimdall.dcserver.local ntopng[1174]: [NetworkDiscovery.cpp:494] ERROR: Send error [1/Operation not permitted]

(Markus Neuberger) #6

Sorry, I can’t reproduce, I don’t see that log entry on 2 servers.

I found some threads in French:

https://performance.izzop.com/book/export/html/384

https://performance.izzop.com/content/ntopng-3-1-utilisateur-non-root

Do you experience something not working because of that error?


(Juan Carlos Fernandez) #7

Actually, I disabled [Network Discovery] on ntopng web UI and the error stopped.