Ntopng access problem


(jack) #1

Hi,

i have a problem with ntopng.
i have correctly installed letsencrypt and it works fine but when i try to go to the webinterface (xxxx.com:3000) i have some cert issue.

Secure Connection Failed

An error occurred during a connection to xxxx.com:3000. SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long)

    The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
    Please contact the website owners to inform them of this problem.

No problem if i go on that page from my android phone…


(Artem Fedai) #2

Because ntop in on HTTP, not https.


(jack) #3

yes! my mistake… sorry!


(jack) #4

but the browser automatically redirect ho https… :pensive:


(Artem Fedai) #5

so make some trick, because SSL port for NTOP is 3001

db configuration delprop ntopng TCPPort 3000
db configuration setprop ntopng TCPPorts 3000,3001
signal-event firewall-adjust
yum install openssl-devel

cat /etc/letsencrypt.sh/certs/your domail/privkey.pem /etc/letsencrypt.sh/certs/your domain/cert.pem /etc/letsencrypt.sh/certs/your domain/chain.pem > /usr/share/ntopng/httpdocs/ssl/ntopng-cert.pem
4) Disable then enable Ntop from WebUI
5) open https://your domain:3001


(jack) #6

when re enabling ntop from webUI: