NS8 Webtop not working (Platform is under maintenance)

I installed webtop 5.21.3 from the software page of ns8 today 2/2/2024. After install I get the webtop login page, but it states Platform is under maintenance. Access is allowed for system administrator only. Also the admin/admin username and password combination are not working (as per the ns8 manual) and no users can log in.

Is there a fix for this? or do I need to bite the bullet and revert to thunderbird to get mail for my 25 odd users.


Matt (the slow turtle who really wants to love ns8 but is finding it as frustrating as he is slow)

what base os are you using

di you install from iso or into os,

is testing repo enabled on your server , if yes, what veersion are you on?

Debian 12 as Rocky Linux failed on the samba on reboot. Found the debian 12 more stable. Running on proxmox, vm has 8 cores, 24GB RAM, 1TB storage.

is testing enable don your server

No :pensive: Just the standard repos.

Still not fixed with latest updates as of today. Is this going to be fixed or am I better off ditching this option altogether?
Is there a way to overwrite the default administrator login. I am now up to webtop4 instance. Is there a way to turn of maintenance?

:frowning: Webtop is not working for everybody in NS8?

Hard disk or SSD/NVMe?
Status of webtop instance services? (probably good)
If it’s a “new” empty install (no user data), did you try removing the app and installing it again?

remove-module --no-preserve webtop1  # replace webtop1 with your webtop app instance

the usual admin / admin pair are the default ones for webtop on NS8.

To reset admin password (replace webtop1 with the name of your instance):

runagent -m webtop1
podman exec -it postgres bash
psql -U postgres -d webtop5
SELECT * FROM "core"."local_vault" WHERE user_id='admin'; # OPTIONAL - Shows current admin password settings
UPDATE "core"."local_vault" SET password_type='PLAIN', password='admin' WHERE user_id='admin';


Then access webtop and disable maintenace:

Over the last week I installed webtop on multiple NS8 VM just for testing and it worked (at least accessing it) but didn’t try much more nor used it extensively.

Hi all.

Here. PATIENCE is the main culprit.

Before access, wait 1-2 even 3 minutes to let the system time to do its job…


1 Like

Maybe some words into NS8 Module page for webtop might be useful.

After removing the existing webtop4 instance with

remove-module --no-preserve webtop4

reinstalling works, but once I try setting the FQDN I get the below.
Configure webtop6

Task module/webtop6/configure-module failed

  • Subtask module/traefik1/set-route is running

  • Subtask module/mail1/reveal-master-credentials completed

Enqueued anchor job 43 postgres.service/start.
Enqueued auxiliary job 60 z-push.service/start.
Enqueued auxiliary job 59 apache.service/start.
Enqueued auxiliary job 61 webdav.service/start.
Enqueued auxiliary job 57 webtop.service/start.
Enqueued auxiliary job 58 webapp.service/start.
Traceback (most recent call last):
  File "/home/webtop6/.config/actions/configure-module/20config", line 240, in <module>
    response = agent.tasks.run(f"module/{mail_module}", action='reveal-master-credentials')
  File "/usr/local/agent/pypkg/agent/tasks/run.py", line 39, in run
    results = runp([taskrq], **kwargs)
  File "/usr/local/agent/pypkg/agent/tasks/run.py", line 50, in runp
    return asyncio.run(_runp(tasks, **kwargs))
  File "/usr/lib/python3.11/asyncio/runners.py", line 190, in run
    return runner.run(main)
  File "/usr/lib/python3.11/asyncio/runners.py", line 118, in run
    return self._loop.run_until_complete(task)
  File "/usr/lib/python3.11/asyncio/base_events.py", line 653, in run_until_complete
    return future.result()
  File "/usr/local/agent/pypkg/agent/tasks/run.py", line 120, in _runp
    return await asyncio.gather(*runners, return_exceptions=(len(tasks) > 1))
  File "/usr/local/agent/pypkg/agent/tasks/run.py", line 129, in _run_with_protocol
    return await run_apiclient(taskrq, **pconn)
  File "/usr/local/agent/pypkg/agent/tasks/apiclient.py", line 78, in run_apiclient
    return tcontroller.result()
  File "/usr/local/agent/pypkg/agent/tasks/apiclient.py", line 191, in _retry_request
    raise exhttp
  File "/usr/local/agent/pypkg/agent/tasks/apiclient.py", line 166, in _retry_request
    retval = await request_procedure(*args, **kwargs)
  File "/usr/local/agent/pypkg/agent/tasks/apiclient.py", line 300, in _acontrol_task
    return await _retry_request(_aread_status, taskctx['status_path'], retry_statuscodes=[400,404], **kwargs)
  File "/usr/local/agent/pypkg/agent/tasks/apiclient.py", line 191, in _retry_request
    raise exhttp
  File "/usr/local/agent/pypkg/agent/tasks/apiclient.py", line 166, in _retry_request
    retval = await request_procedure(*args, **kwargs)
  File "/usr/local/agent/pypkg/agent/tasks/apiclient.py", line 118, in _aread_status
    jresp = await resp.json()
  File "/usr/local/agent/pyenv/lib/python3.11/site-packages/aiohttp/client_reqrep.py", line 1104, in json
    raise ContentTypeError(
aiohttp.client_exceptions.ContentTypeError: 0, message='Attempt to decode JSON with unexpected mimetype: ', url=URL('http://cluster-leader:9311/api/module/mail1/task/045a6f8d-38e8-4088-8b23-a0e6ede3ec10/status')

Any idea how to fix. I get the same response using the GUI and the terminal when installing. Is there anyway I can specifiy the instance using add-module so that I don’t end up with webtop6, webtop7,webtop8, etc as I try to fix this,