NS8 - virtual host disappearing

Could you clarify this? Because it isn’t what I’m seeing. I create a virtual host, it appears in the UI. I create a second virtual host, and both appear in the UI. This is in NS8B2 on Debian 12.

Debian-12 / NS8b2

I installed Nginx and MariaDB.
Created a VirtualHost (#1).
Using phpMyAdmin I created a DB, a user, and gave him all the rights.
At the command line, I connected to MariaDB and verified DB and user.
With SFTPgo, copied WordPress in 9001 directory.
Extract WordPress
Adjusted owner/group.
Using Firefox, go to the URL and I intalled/confifured WordPress.
I verify the configuration of WordPress
I installed a new Theme.
I created a Page.
All is working as it should.

Created another VirtualHost (#2).
The first one disappeared from the UI.


1 Like

Have you been able to duplicate this behavior? I’m not seeing it after just creating two virtual hosts (both of them appear as expected at webserver1 → Virtual Hosts), but I haven’t tried installing anything in particular in either of them as yet–that will probably need to wait for a bit.

I corrected the plural in your title.


Why you deleted my answer to your reply?

Same thing for your reply.


I didn’t delete it; I moved it from the other topic (where you posted it) to this one. You then edited it to say something completely different.



I suggest we hold off on this for now, nobody is at fault. A misunderstanding.

1 Like

From now on, I will never comment or reply to this guy.


Here’s the edit history:

Discourse isn’t all that intuitive, so it could easily have been a mistake. But that’s nonetheless what happened.

@michelandre I am trying to get Wordpress working on a virtual host too, just like you. But I am struggling with making the connection to the db. What did you fill out as a host? localhost or something else?

2nd, I did not change any permissions on the unzip Wordpress files, but I can access the wp-admin pages…?


Ps. also see Installing Wordpress on virtualhost

Hi @LayLow

You have to use phpMyAdmin to create the database and mainly the user.
phpMyAdmin is included with the installation of MariaDB.
For the user, you have to check the access from external => it will add a % at the end of the user name.

In wp-config.php:

define( 'DB_HOST', 'domain.tld:20010' );

i.e. => define( 'DB_HOST', 'toto-dev.org:20010' );

In the root directory of the VirtualHost (9001 for the first one), check the owner:group of this directory.
chown -R owner:group /path/to/directory/9001

To know the exact owner:group, you can login to SFTGgo with the user/pswd 9001/9001 and upload a small file. Then you can look at the owner:group of that file to use them for the above chown command.

Good luck,


You should create a new topic for NS8/WordPress.

Thanks! Is this a specific port tied to the virtual host or?

It is on the description of the DB somewhere on the UI.

cluster-admin // Mariadb1 // Settings



Yep, works! Merci!

One more thing…

What’s wrong?

This is the default WordPress page.

Edit it and put inside it whatever you want.


I have the feeling that I am missing out on the page markup. Normally the default slash page is nicer looking. Also when I log in into the admin section I only see links and an ugly page.

I tried changing PHP version on the virtual host, but no difference.

If you are francophile, have a look at:

Remember, Google Translate or DeepL or … might be your friend !