Ns8 testing with webtop

NethServer Version: NS8 last update
Module: webtop

Hey Guys, i play around with the NS8 Server and try to install webtop on it. Have no luck, allways getting this error:

“context”: {
“action”: “configure-module”,
“data”: {
“hostname”: “webtop.ns8.test”,
“locale”: “de_DE”,
“mail_module”: “mail1”,
“request_https_certificate”: false,
“timezone”: “Etc/UTC”,
“webapp”: {
“debug”: true,
“max_memory”: 1024,
“min_memory”: 512
“webdav”: {
“debug”: false,
“loglevel”: “ERROR”
“zpush”: {
“loglevel”: “ERROR”
“extra”: {
“description”: “Configuring”,
“eventId”: “a61c1f3e-e1d6-410e-9df1-cf8a67eefba5”,
“title”: “Configure webtop2”
“id”: “2292c3c9-b21f-460d-adad-5b4559bf74d5”,
“parent”: “”,
“queue”: “module/webtop2/tasks”,
“timestamp”: “2023-08-24T10:06:25.509462291Z”,
“user”: “admin”
“status”: “aborted”,
“progress”: 20,
“subTasks”: [],
“validated”: true,
“result”: {
“error”: “A dependency job for postgres.service failed. See ‘journalctl -xe’ for details.\n”,
“exit_code”: 1,
“file”: “task/module/webtop2/2292c3c9-b21f-460d-adad-5b4559bf74d5”,
“output”: “”

any suggestions?

we need some input to debug, postgresql has failed to start

try to debug by filtering the logs

journalctl _UID=$(id -u webtop2) -e

what is your resource for the hypervisor, spinning drive, ssd, how much cores and ram you have given to the VM


config VM Proxmox

i tried to filtering the logs, but i didnt make it :frowning:
to be honest i got no log from the app webtop2

1 Like

One core is not enough. Minimal is 2cores and 2 gb but like any game boxes you cannot play well with the minimal written on them

I suppose you use spinning drive ?

i changed it to 2 cores memory is 5 gb and no, it is a ssd drive

1 Like

i did the whole vm new under rocky linux and i was able to install webtop. but i am not able to log in. any suggestions?
2023-08-31T08:59:00+02:00 [1:webtop1:webapp] 2023-08-31 06:59:00 [ERROR] c.s.webtop.core.bg.ReminderTask - Error
2023-08-31T08:59:00+02:00 [1:webtop1:webapp] org.apache.shiro.authz.AuthorizationException: com.sonicle.webtop.core.app.sdk.WTNotFoundException: SID not found for ‘admin@
2023-08-31T08:59:00+02:00 [1:webtop1:webapp] at com.sonicle.webtop.core.app.shiro.WTRealm.doGetAuthorizationInfo(WTRealm.java:173)
2023-08-31T08:59:00+02:00 [1:webtop1:webapp] at org.apache.shiro.realm.AuthorizingRealm.getAuthorizationInfo(AuthorizingRealm.java:342)
2023-08-31T08:59:00+02:00 [1:webtop1:webapp] at org.apache.shiro.realm.AuthorizingRealm.hasRole(AuthorizingRealm.java:576)
2023-08-31T08:59:00+02:00 [1:webtop1:webapp] at org.apache.shiro.authz.ModularRealmAuthorizer.hasRole(ModularRealmAuthorizer.java:374)
2023-08-31T08:59:00+02:00 [1:webtop1:webapp] at org.apache.shiro.mgt.AuthorizingSecurityManager.hasRole(AuthorizingSecurityManager.java:153)
2023-08-31T08:59:00+02:00 [1:webtop1:webapp] at com.sonicle.webtop.core.app.RunContext.hasRole(RunContext.java:510)
2023-08-31T08:59:00+02:00 [1:webtop1:webapp] at com.sonicle.webtop.core.app.RunContext.hasRole(RunContext.java:506)
2023-08-31T08:59:00+02:00 [1:webtop1:webapp] at com.sonicle.webtop.core.app.RunContext.isSysAdmin(RunContext.java:497)
2023-08-31T08:59:00+02:00 [1:webtop1:webapp] at com.sonicle.webtop.core.app.RunContext.isSysAdmin(RunContext.java:254)
2023-08-31T08:59:00+02:00 [1:webtop1:webapp] at com.sonicle.webtop.core.app.RunContext.isSysAdmin(RunContext.java:245)
2023-08-31T08:59:00+02:00 [1:webtop1:webapp] at com.sonicle.webtop.core.sdk.BaseManager.(BaseManager.java:77)
2023-08-31T08:59:00+02:00 [1:webtop1:webapp] at com.sonicle.webtop.core.CoreManager.(CoreManager.java:257)
2023-08-31T08:59:00+02:00 [1:webtop1:webapp] at com.sonicle.webtop.core.app.ServiceManager.instantiateCoreManager(ServiceManager.java:816)
2023-08-31T08:59:00+02:00 [1:webtop1:webapp] at com.sonicle.webtop.core.app.WT.getCoreManager(WT.java:399)
2023-08-31T08:59:00+02:00 [1:webtop1:webapp] at com.sonicle.webtop.core.bg.ReminderTask.executeWork(ReminderTask.java:75)
2023-08-31T08:59:00+02:00 [1:webtop1:webapp] at com.sonicle.webtop.core.sdk.BaseBackgroundServiceTask.doExecuteWork(BaseBackgroundServiceTask.java:91)
2023-08-31T08:59:00+02:00 [1:webtop1:webapp] at com.sonicle.webtop.core.sdk.BaseBackgroundServiceTask.execute(BaseBackgroundServiceTask.java:71)
2023-08-31T08:59:00+02:00 [1:webtop1:webapp] at org.quartz.core.JobRunShell.run(JobRunShell.java:202)
2023-08-31T08:59:00+02:00 [1:webtop1:webapp] at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:573)
2023-08-31T08:59:00+02:00 [1:webtop1:webapp] Caused by: com.sonicle.webtop.core.app.sdk.WTNotFoundException: SID not found for 'admin@

2023-08-31T08:59:00+02:00 [1:webtop1:webapp] at com.sonicle.webtop.core.app.WebTopManager.lookupSubjectSid(WebTopManager.java:652)
2023-08-31T08:59:00+02:00 [1:webtop1:webapp] at com.sonicle.webtop.core.app.WebTopManager.getComputedRolesByUser(WebTopManager.java:2186)
2023-08-31T08:59:00+02:00 [1:webtop1:webapp] at com.sonicle.webtop.core.app.shiro.WTRealm.loadAuthorizationInfo(WTRealm.java:384)
2023-08-31T08:59:00+02:00 [1:webtop1:webapp] at com.sonicle.webtop.core.app.shiro.WTRealm.doGetAuthorizationInfo(WTRealm.java:170)
2023-08-31T08:59:00+02:00 [1:webtop1:webapp] … 18 common frames omitted

one blind shot

do you have installed an ldap (openldap or samba4) do you have created an admin user (administrator is the default)

1 Like

right about the dc samba. and no, i did not have an admin user, administrator yes.

1 Like

try with administrator

i tried with all possibilities, also with @domain and without. is there a different login for administrator or user of webtop? like webtop.domain.xx/login or webtop.domain.xx/admin?

administrator with the password you set when you have created the domain

is there a plan to migrate Sogo für the NS8 environment?


I also installed WebTop on NS8 and it works without problems.
The difference is that I use LDAP, not Samba4.
Can it be a WebTop problem in combination with Samba4?
However, you should be able to log into WebTop with the default WebTop administrator credentials:
user: admin
password: admin

unfortunately is this the main problem, i did not reach the configuration UI for webtop, not with the admin admin, not with the build in administrator from the samba dc etc.

Do you have something like this in the “webtop1” module?

WebTop virtual host (FQDN): webtop.yourdomain.tld

1 Like

yes, sure i have the fqdn, it works perfect but the login is my problem

Have you reached this page?
(Using your FQDN, of course.)
If yes, then you should be able to log in with admin / admin

yes i reach perfectly this GUI but have no luck with login

1 Like

Can you create in Samba4 a new user: admin / admin and try after that?

it is not possible during password security of NS8/Samba AC