NS8 rerverse (websocket) proxy for webmin and jupterhub

Testing / migrating the functionality of my NS7 setup to NS8 stumbling on getting one specific reverse proxy wich returns the utterly useful message: Internal Server Error
Not being skillful in this stuff have a hard time to debug it.

One thing though: the web services running on that box are (python) jupiterhub and webmin, both need that websocket proxy thingy enabled.
(in apache : RewriteCond %{HTTP:Upgrade} websocket [NC]

My question before diving in to al kinds of rabbitholes:
Does treafik proxy websockets too?

Hi @mark_nl

AFAIK, that’s a speciality of Traefic…


See their webpage…

My 2 cents

yes thought so…

NS7 (working)

NS8 (internal server error)

tried with and without http to https.

target is nginx as reverse proxy with valid certificate.
Any leads?

If the backend has a valid certificate, try to replace the IP with its hostname in the URL field.

However with the latest core update, you can also keep the IP and disable the TLS certificate validation (thanks to @stephdl)!

1 Like