NS8, not able to list/add users/groups

Hi all,

I am giving NS8B2 a try on my VPS host (Contabo). I have installed Rocky 9 and followed NS8 install documentation. I can enter the closer admin guy and configure the node and install LDAP (local node1), but is throws me an error:

Traceback (most recent call last):
File “/var/lib/nethserver/cluster/actions/list-domain-users/50list_users”, line 33, in
users = Ldapclient.factory(**domain).list_users()
File “/usr/local/agent/pypkg/agent/ldapclient/init.py”, line 29, in factory
return LdapclientAd(**kwargs)
File “/usr/local/agent/pypkg/agent/ldapclient/base.py”, line 37, in init
self.ldapconn = ldap3.Connection(self.ldapsrv,
File “/usr/local/agent/pyenv/lib64/python3.11/site-packages/ldap3/core/connection.py”, line 363, in init
File “/usr/local/agent/pyenv/lib64/python3.11/site-packages/ldap3/core/connection.py”, line 387, in _do_auto_bind
File “/usr/local/agent/pyenv/lib64/python3.11/site-packages/ldap3/strategy/sync.py”, line 57, in open
BaseStrategy.open(self, reset_usage, read_server_info)
File “/usr/local/agent/pyenv/lib64/python3.11/site-packages/ldap3/strategy/base.py”, line 146, in open
raise exception_history[0][0]
ldap3.core.exceptions.LDAPSocketOpenError: socket connection error while opening: [Errno 111] Connection refused

Sounds/seesfamiliar anybody please? I’ve also deleted the LDAP instance and re-tryed with Samba, same issue.


1 Like

the ldap module is unresponsive probably or not well installed, the list user action throw an exception about connection refused…what ldap did you choose, samba4, openldap ?

what are the resources you allocated to the VM Ram, cpu

Bonjour Stéphane, ça va?

I first tried LDAP, when that thew the error, I removed the instance and tried samba which results in the same error.

Specs are:

6 vCPU Cores




100 GB NVMe

or 400 GB SSD


2 Snapshots

1 Like

You gave to the vm running ns8 6vcore and 16gb of ram…you are worse than me…are you sure ?

I spoke what are the ressources of the VM running NS8 ?

Alternatively does the systemd redis is running ?

systemctl status redis

[quote=“stephdl, post:5, topic:22250”]
systemctl status redis
[/quote[root@srv1 ~]# systemctl status redis
● redis.service - Core Redis DB
Loaded: loaded (/etc/systemd/system/redis.service; enabled; preset: disabl>
Active: active (running) since Fri 2023-09-29 22:42:41 CEST; 1 day 23h ago
Docs: GitHub - NethServer/ns8-core: NethServer 8 Core modules
Main PID: 19400 (conmon)
Tasks: 1 (limit: 100413)
Memory: 652.0K
CPU: 1.674s
CGroup: /system.slice/redis.service
└─19400 /usr/bin/conmon --api-version 1 -c e65add1e798cc38ab46af85>

Oct 01 21:46:15 srv1 redis[19400]: 1:M 01 Oct 2023 19:46:15.963 * 1 changes in >
Oct 01 21:46:15 srv1 redis[19400]: 1:M 01 Oct 2023 19:46:15.971 * Background sa>
Oct 01 21:46:16 srv1 redis[19400]: 459:C 01 Oct 2023 19:46:16.037 * DB saved on>
Oct 01 21:46:16 srv1 redis[19400]: 459:C 01 Oct 2023 19:46:16.038 * Fork CoW fo>
Oct 01 21:46:16 srv1 redis[19400]: 1:M 01 Oct 2023 19:46:16.076 * Background sa>
Oct 01 21:46:22 srv1 redis[19400]: 1:M 01 Oct 2023 19:46:22.028 * 1 changes in >
Oct 01 21:46:22 srv1 redis[19400]: 1:M 01 Oct 2023 19:46:22.030 * Background sa>
Oct 01 21:46:22 srv1 redis[19400]: 460:C 01 Oct 2023 19:46:22.050 * DB saved on>
Oct 01 21:46:22 srv1 redis[19400]: 460:C 01 Oct 2023 19:46:22.050 * Fork CoW fo>
Oct 01 21:46:22 srv1 redis[19400]: 1:M 01 Oct 2023 19:46:22.131 * Background sa>
lines 1-21/21 (END)

Not sure what you mean, these are the specs of the VM soles for NS8

Look at the Logs page. You could select the Samba instance and see if there is some clue among the log records.

yes two failed modules it is a lot :-?

This is wat I did:

  1. Install Rocky 9
  2. Follow NS8 install docs with the install command
  3. Got to cluster admin interface
  4. Configure cluster (1 node only as master)
  5. Select ldap as account provider from Software center
  6. Add groups / users
  7. error as described
  8. Tried all kinds of things which fail due to error


1 Like

nothing curious, maybe some curious networking could do it, we need the log of installation and usage of each module eg openldap1 or samba1. (installation and usage)

something common block your system

Hi @LayLow,

I have reproduced your installation on my Proxmox. BaseOS Rocky 9.2, 4 CPU cores, 8 GB RAM and 100 GB disk. I proceeded exactly as you described. Users and groups can be created without problems.




I’ll start from scratch then. Thanks for your efforts, appreciated!

Keep you posted.

1 Like


Exact same issue. Details show the exact same error message (unable to connect).

PM me for root access if you like


your issue raises early you can even not list the default administrator user, maybe something specific to contabo

1 Like

Thank you for your journal file.

For everyone else, to get a dump of recent records:

journalctl > journal.txt

The same information can be obtained from the Logs page, filtering for a specific node.

About the issue, I suspect it is a bug in the Ldapproxy, which tries to bind a missing IPv6 loopback address. The failure of both Samba and OpenLDAP user listings is just a symptom of that.

This is the log evidence:

Oct 02 23:08:29 srv1 ldapproxy[20659]: 2023/10/02 21:08:29 [emerg] 1#1: bind() to [::1]:20001 failed (99: Address not available)

@LayLow can you confirm that the Contabo VPS has no IPv6?

Filed card in Trello

1 Like

I did not configure it. By default it has an IPV6 in the vps config panel, but I did not use it.


Please, next time you fire a VPS on Contabo look at the output of ip -6 addr: does it contain ::1 ?

Will do this evening, on the move atm. And thanks a lot!

Update: sent to @davidep per DM due to sensitive info.

The bug should be fixed in the upcoming release