NS8 - Nextcloud Email notifications

NethServer Version: NS8 (how can i see the Core Version?)
Module: Nextcloud-App 1.1.6
(Nextcloud 27.1.7)
Package nextcloud-app · GitHub

Preliminary remark: I have been testing the NS8 and its various apps regularly since an early NS8 beta version and also carry out regular updates. I have not yet performed a clean reinstallation (with the release state). I have also not yet performed a service and data migration; first the NS8 has to run smoothly with all the functions provided.

For example, I like to use Nextcloud, so the functioning of certain functions is very important to me.

I have problems sending Nextcloud messages. In earlier versions (Nethserver 7) this worked well, here you could use either “sendmail” or “smtp” (via the Nethserver 7 mail server) to send. In principle, this always worked, except after Nextcloud updates, then the smtp settings were reset. This error was not fixed, so from then on I used sendmal - it didn’t survive a Nextcloud update either, but it was easier to set up again.

Now, of course, Nextcloud should also be able to send emails under NS8. I haven’t managed to do that yet - at least not with sendmail and not with the NS8 internal Mail.app. The Mail.app as such works, I can use it to send and receive emails, e.g. via SOGo but also externally via IMAP/SMTP. So I have working SMTP access data.

However, using the “usual” access data does not work in internal Nexcloud use. Even the test send is acknowledged with an error:

“There was a problem sending the email. Please check your settings. (Error: Email could not be sent. Check your email server protocol)”

The current NS8 instructions say the following about “Email notifications”:

“If a Mail application instance is already installed in the cluster, choose the Use Mail app instance option.”

This option is not displayed in Nextcloud, only Sendmail and SMPT - and neither of them work for me.

“Then refer to the section Relay for further information about the configuration of Mail.”

This section states:
“When a message is received from another mail server (MTA), or from a mail user agent (MUA), Postifx decides how to relay it towards its final destination.”

As far as I understand, using “SMTP” in Nextcloud is equivalent to a MUA. In this case, definitions in the “Relay” section should not be necessary, right?

“Typically the decision is based on the domain suffix of the recipient address.
If the domain is handled by Postfix (i.e. it is listed in Domains) the message is delivered locally.”

The destination address for Nextcloud (for status messages) is used by Postfix (at least I didn’t define anything else).

“Otherwise, if the domain is external, the message destination server (also known as “next-hop” server) is found with a MX DNS query.”

Of course, this type of sending does not occur because the sending of the test messages (via MUA) fails.

“The Relay page allows to configure a set of rules that overrides the external domain resolution based on DNS.”

That sounds great, but should that only be necessary in special cases?

Why doesn’t the Nextcloud MUA “talk” to my NS8 Postfix or Dovecot?

I use the same access information as usual, or as it works in other MUAs, i.e. server name, port, SSL or TLS (tried both), username/password combination, etc.


This could be the issue.
I still have one client in a similiar state…
All others are migrated or created new - and are working (more or less, eg Zabbix is still missing…)

Note: I had almost NO issues on all the new installed NS8. I only had issues on migration of some NS7, especially those long running and with diverse “tweaks”, like for Samba / AD.

Probably you need the help of @davidep (Like I did!).

My 2 cents

Dear Andy, thank you for your answer.

That means that the system mail sending from Nextcloud works in more recent or “clean” installations of NS8 or the Nextcloud app?

Or is the “Mail App” option available as a sending option in Nextcloud?

In the early versions (including one after the release) I occasionally carried out a (parallel) reinstall (with partial configuration) to see if errors had been resolved. If the errors were still there, I stuck with the previous installation.

It seems that you are already using various instances of NS8 or have access to them. Could you answer a few questions for me about whether things that are not (yet) working for me are already working for you?

Would probably be better via PS?

1 Like

On a support call right now, but not NS related…

PM would probably be better…

My 2 cents