NS8 - connection problem between Nextcloud and Collabora for using Nextcloud Office

NethServer Version: NS8 on Rocky Linux 9.4
Module: Nextcloud, Collabora

Hello everyone!

Please help me to solve the connection problem between Nextcloud and Collabora for using Nextcloud Office.
Nextcloud and Collabora are installed on the same NS8 server and apparently both work correctly (the same configuration on NS7 works without problems) (please see the attached files).

In System logs for nextcloud4 - Node1, at the end of the connection attempt to collabora.gtbs.ro, appears: (please see the attached files - sorry for the format…).

It’s more than likely a configuration problem, but I don’t know how to solve it myself, even if I searched through the forum.

Thanks in advance for your help!

Just checking, you did not upgrade manually via the Nextcloud GUI did you?

No, NEVER! Only from NS.

curl got a timeout, try to restart collabora, do you see the OK when you reach the collabora’s URL

I restarted many times, reinstalled many times (now it’s the 4th time) both modules (nextcloud and collabora) and got the same problem.
I saw that long timeout.
Yes, for https://collabora.gtbs.ro I see OK.

NS8 is in the DMZ with port forwarding of the public IP (80, 443) to the IP in the DMZ.
I use the same configuration on the old NS7 and there everything worked correctly from the beginning.

Maybe this helps?

Thank you, but unfortunately it doesn’t help me.
Just now I rebooted the old NS7 and everything is working normally with the network settings (PortForwarding/NAT) that I normally use.
However, for NS8, I’ve tried all PortForwarding/NAT configuration possibilities without any good results.

Sorry, I am out of options here.