NS8 admin password not function

NethServer Version: NS8
Module: admin

Installation with Debian 11, with the given password for admin

Cannot log in

Invalid username or password

Hello Peter!
Thank you for joining the community and test NS8.

We need a little more info to know how to help you.
So please, let’s try to respond to some questions:

  • how did you install it? From scratch or using a pre-built image?
  • where are you trying to login? On the UI or on the terminal with SSH?
  • did you try with the default admin password Nethesis,1234?

New installation Debian 11 - update and upgrade, reboot
curl https://raw.githubusercontent.com/NethServer/ns8-core/main/core/install.sh | bash
admin / Nethesis,1234

Works with Alma Linux!

1 Like

I’m glad it works with Alma, but it should work also with Debian.
I just did it without troubles.
If you still have the machine, you could inspect the content of redis for user admin.
Execute: redis-cli acl getuser admin, you should get something like:

 1) "flags"
 2) 1) "on"
 3) "passwords"
 4) 1) "648a5db6b14800f4009f62ec6bdbd04b91b6b25179c92626839e3a91fb32da5e"
 5) "commands"
 6) "-@all"
 7) "keys"
 8) ""
 9) "channels"
10) ""
11) "selectors"
12) (empty array)

You can also try to reset the password with the following commands:

redis-cli acl setuser admin nopass
redis-cli acl setuser admin \>Nethesis,1234

And make sure the api-server is running with systemctl status api-server

1 Like

Those commands are good for a single-node cluster (like a fresh installation). In the general case it is better to use this command (to be added to the manual):

api-cli run alter-user --data '{"user":"admin","set":{"password":"Nethesis,1234"},"revoke":[],"grant":[]}'

In the future, once the bug fix below has been released, the command will be shorter:

api-cli run alter-user --data '{"user":"admin","set":{"password":"Nethesis,1234"}}'
1 Like

I tried again with a fresh installation and I think the problem starts earlier:

Start API server and core agents:
Created symlink /etc/systemd/system/multi-user.target.wants/api-server.service → /etc/systemd/system/api-server.service.
Created symlink /etc/systemd/system/default.target.wants/agent@cluster.service → /etc/systemd/system/agent@.service.
Created symlink /etc/systemd/system/default.target.wants/agent@node.service → /etc/systemd/system/agent@.service.
Grant initial permissions:
Install Traefik:
<7>podman-pull-missing xxx_traefik:0.0.12 (removed link due new user)
Trying to pull xxx_traefik:0.0.12… (removed link due new user)
Getting image source signatures
Copying blob sha256:09162905b8134233771eb175fd33ed61e4af6df9fc3b9091950afbcd88df4aae
Copying blob sha256:09162905b8134233771eb175fd33ed61e4af6df9fc3b9091950afbcd88df4aae
Copying config sha256:19d93e981c33f9f41bae92b525644f133cfdd431fbdb8cec171d43183fda455b
Writing manifest to image destination
Storing signatures
<7>extract-ui Package traefik · GitHub
Extracting container filesystem ui to /var/lib/nethserver/cluster/ui/apps/traefik1
Assertion failed
File “/var/lib/nethserver/cluster/actions/add-module/50update”, line 202, in
agent.assert_exp(create_module_result[‘exit_code’] == 0) # Ensure create-module is successful

I got the same error with Rocky Linux 9.1 but I uninstalled NS8 and tried to reinstall so I thought the uninstall didn’t work but maybe it has nothing to do with the uninstall: :thinking:

1 Like