Ns7b2 LightSquid diagnostic

Hi;

with Nethserver 7b2
I have this error message :

Li**gthS**quid diagnostic.
Error : report folder ‘/var/lightsquid’ not contain any valid data! Please run lightparser.pl (and check ‘report’ folder content)
Please check config file !

Variable	value
$tplpatph	/usr/share/lightsquid/tpl
$templatename	nethesis
$langpatph	/usr/share/lightsquid/lang
$langname	eng
$reportpath	/var/lightsquid
Access to '/var/lightsquid' folder	yes
$graphreport	1
folder content:

1st: It had a missspelling LightSquid not LigthSquid
Second: I tried to run lightparser.pl and nothing happen

In my /var/log I just have ./squid & ./squidGuard
no ./ligthSquid or ./lightSquid

squidclamav and squid services are active and running

The only log I could find about this service is this :
****** esmith::event[32552]: Event: nethserver-lightsquid-update SUCCESS
So apparently the update worked.

Does it work after running this?

/usr/sbin/lightparser.pl -y /var/log/squid/access.log

nope :frowning:

still have the same error

but I have activities into my /var/log/squid/access.log

The misspelled word seems to be from upstream.
Installed webproxy, webfilter, generated some traffic, and the reports showed right after running lightparser.pl
Sorry, I cannot reproduce the problem.

Does it throw any error when running lightparser.pl -d

I reinstall it and have the same issue

Do you have some data to parse into your access.log file?

1 Like

You will have informations there after midnight.
Till then, you will see this windows.
Please wait till tomorrow.
If I remember well, the logrotate is set to “daily”.

Edit:
And of course, you must have some traffic through proxy.

Lightsquid Cache Timing Interval

Light-squid cache

1 Like