NS7 Installation problems in VPS


I’m trying to get NS7 working on a KVM VPS where I previously had NS6.8 working without a problem, but the system breaks in the first software update. I can Install and reach the server at first; I go to the Software centre and it notifies me of the many updates. I go through the update process and at the end of it the server becomes unreachable.

When rebooted, I notice that the update installed a new core that replaced the original NS7 as default. Choosing the older centos option, the system boots without errors but the system is still unreachable either on the web panel or by ssh.

I log in through VNC and issue a db network show which tells me that the ens3 device is misconfigured (no gateway, DHCP, no net mask… I edit the relevant ifcfg-ens3 file and restart network service but the server is still unreachable.

I have now tried this procedure 3 times and every time i end up with a dead server after the initial software update.

Is there any proper way to apply the updates without breaking the server?

1 Like

Hi, thanks for the report.

Does the VPS uses special static routes (like OVH)?
I also know there is a problem on CentOS with multiple interfaces using DHCP: maybe you have multiple interfaces configured with DHCP?

If you want to reconfigure the network, you should use the networks db. Take a look here: http://docs.nethserver.org/projects/nethserver-devel/en/v7b/nethserver-base.html

Hi @giacomo,

Thank you for your reply and assistance. The VPS does not work with static routes, it has a direct link to the gateway.

When Nethserver install it does it with dhcp enabled by default. I have tried changing it to static but the result is the same, it looses connectivity after restart.

I am now trying to install NS 7 beta 1 and I find even more problems - this time the server is not reachable after install. I was about to open a new ticket about it.

I notice that the default is dhcp - I have also tried changing this in the install panel and change it to manual and configured ip, netmask and gateway manually. The result is always the same: the installation seems to go through without a problem but when it reboots it takes me to the CentOS login window:

CentOS Linux 7 (Core)
Kernel 3.10.0-327.e17.x86_64 on an x86_64

If I reboot the VPS manually through the control panel, it then leads me to the NS login shell, but only on the second reboot after installation:

Nethserver release 7.2.1511 (beta1)
Kernel 3.10.0-327.e17.x86_64 on an x86_64

I also note that when I configure the network setting mannually, it does not recognize the eth0 MAC address automatically; Also, when I login in shell through VNC (the only way to access the server as it is unreachable via ssh), the ifcfg-ens3 device (the ethernet device) also does not list the Hardware address.

Still, unable to reach the web panel or shell via ssh…

Is it possible to install the beta from command line instead of iso? Really would like to try the new version.


1 Like

See http://docs.nethserver.org/en/v7b/installation.html#install-on-centos

From CentOS 7:

yum localinstall -y http://mirror.nethserver.org/nethserver/nethserver-release-7.rpm

Thanks @dnutan

I tried finding the wiki for ns7 before but never managed to. I did manage to install NS6.8 correctly following the similar guide so going to give it a shot. Tired of re-configuring network devices, and cant even be sure that is the issue. Everything seems well set up, yet I cant establish connection to the server…

Will install through shell and will report back.

The manual installation fails as well.

I get multiple errors for several processes; this is what i get from journalctl -xe

Any idea why the failed report?

Thanks for the help.

edit: the server again becomes unreachable by ssh - if i log off I am unable to establish connection again.

I have now tried it in a different KVM VPS where I previously had NS6.8 installed and the result is exactly the same…

I have tried configuring dhcp and static network configuration, i have tried installing it from shell. I even tried different network devices - virtio and realtek) and I cant even get through with ssh to the server.

Not being ready out-of-the-box for deployment on a self-hosted VPS should really be addressed in my opinion. With 6.8 I never had a problem installing or updating but I never managed to get NS7 installed.

Any help would be much appreciated.


1 Like

The whole thing seems strange to me since we user both KVM and VirtualBox to develop NethServer.

Just to be clear, these are the steps to replicate the issue:

  • Create a VM on KVM with one bridged interface
  • The bridged interfaces takes an IP address from DHCP
  • After nethserver-install command, the machine can’t be reached

Am I right?

Hi @giacomo,

Thank you for the reply.

  • I log in to the KVM and mount the iso - change the setting to boot from disc.

  • There is no bridged interface - the VPS does not have a private and public ip, only a public ip (like a normal VPS). I had Nethserver 6.8 configured with static address (I have no VPS out of the 14 I control wuith differnet providers that uses DHCP for network configuration

  • I boot from the cd and go to the install pannel. I proceed with the required settings and installation. The install seems to go through fine.

  • After reboot, I cant access Nethserver by ssh or https - the only way to log in is through the provider’s VNC access.

  • I have tried this procedure in two different VPS (both KVM with eth0 device) and the result is the same. Both of those install NS 6.8 without an issue.

I would be happy to provide you temporary access to the VPS so you can replicate the problem, if you wish.

Thank you for the assistance.

1 Like

Furthermore, when I try to install from shell it ends in a failed install (see pastebin journal in a post above)

Yes thanks!

@StreetGuru helped a lot on catching a new bug: https://github.com/NethServer/dev/issues/5068

It should be already fixed :slight_smile:


thank you to @giacomo for the prompt and helpful assistance, I’m glad I could be of some help to the project given my limited abilities. have a brand new NS to try :slight_smile: