NS update broke nextcloud

I was prompted by NS to upgrade. So … I clicked the button. Now I can’t get into nextcloud because I’m in a permanent loop - I allowed nethserver to proceed with a core upgrade - now nextcloud is at 20.0.1 as part of that process However nextcloud 1. still brings up the update page 2. nextcloud is already at 20.0.1 yet brings up an update page for 20.0.1 then fails. I have no access to my files and nextcloud support suggest the fault lies with NS as the version updates are to be applied incrementally. Don’t bother giving me command line fixes … I as many many of your users am not that technical. I had access to my files and now thanks to the NS update script … I don’t.

I guess I won’t, then. Good luck to you.

1 Like

On one of my servers the Nextcloud update worked and I was able to login afterwards. Do you get errors? Maybe a Nextcloud app that makes problems?

As @danb35 already pointed out: We need the command line if the web UI does not work. You may use the terminal in the server manager.

There are some possible solutions in the wiki.

I have 3 admin users … if I toggle to terminal within NS it tells me I’m not allowed … to do virtually anything.


Hi Justin

Linux is in that sense very much like Windows… The CMD, or also PowerShell almost always needs a “Run as Administrator” to do much, even if you are already Administrator of your local box.

In Linux, you need to become the “root” user, or use sudo to run the command as su (root).
In Windows sudo is called runas.exe…

If you are on a linux console, try the command:

su -

This will need the root password to succeed, but afterwards you have all options open.
The command “su” means superuser, and that means root. The “-” afterwards passes the Environment of the used user (here: root!) to your console.

Do you have regular backups? Very Important!

My 2 cents

1 Like

You may need to login as root, then the web terminal in cockpit should work.

1 Like

have no credentials in that regard - tried default - as I don’t remember ever going through a process to change root credentials … but couldn’t get in. i now have files locked away inside a server I wish I had never started using.

Ok - got into terminal. Now what?

Which Nextcloud version did you have before the update?

grep version /usr/share/nextcloud/config/config.php

For reference: thread on nextcloud forum.

Thx for the command. It came back with


yum downgrade nethserver-nextcloud-1.14.2-1.ns7

That shall downgrade Nextcloud 20.x.x to v19.x.x.
Check if Nextcloud is working.

If after that it is working but you want to update to Nextcloud 20.0.1, run:

yum update nethserver-nextcloud

THX THX THX THX so much !!!
I have access to my files.
I did not execute the second (upgrade) command you provided as wanted to first ask you - is it at all likely that I’ll end up back without access/update warnings?

No is it not likely. The problem was skipping a major version (version between v18 and v20).
On Nextcloud admin panel you might see some warnings (like a warning message regarding incomplete database colums, solvable reading the wiki Markus posted above), but nothing that shall prevent Nextcloud usage. Some nextcloud app might be disabled during the upgrade but can be updated/enabled afterwards.

Of course, if a major version is skipped again in the future you might find yourself in the same situation. Same would have happened on a manually installed instance of nextcloud from its sources and manually upgraded to the latest version without checking versions (maybe from the web updater they take care of version upgrade locking, but that does not happen on yum packages we are using).


It would probably help to start doing what @Andy_Wismer suggested and create a data backup job so that you have a backup of your data somewhere easily accessible just in case.

1 Like

Good and supportive replies, guys. To a not very friendly or polite suppoert request. God job, community. I like <3


Hint for the next round:

  • keep more attention (monthly, at least) for updates
  • subscribe
1 Like