NS and mailman lists

NethServer Version: 7.9.2009
Module: email

I managed to install mailman version 2.1.15 on NS. It’s running as a service, I migrated old mailing lists from SME 9.2. This is all working through the mailman gui.

In libreoffice it’s possible to send a document as an email. Of course the client has to be configured to send the email to the NS. For a first test I just emailed to an email-address outside - NOT to a list of mailman. This is working instantly and perfect.

BUT mailing to a list i.e. “test” migrated from SME to mailman, gives an error from the libreoffice client:

<class ‘smtplib.SMTPRecipientsRefused’>: {‘Test@xxx.de’: (550, b’5.1.1 Test@xxx.de: Recipient address rejected: User unknown in virtual mailbox table’)}

Does there has to be a user and a mailbox named in this case “Test” on the NS?

Any help is appreciated.


Creating a user named “Test” leads to local delivery of the email. It seems, the NS does not know how to interact with mailman and lists created in mailman.

Hmm, what do I miss? Googling around tells thet centos7 and mailman should work together.

Coming closer:

In /etc/postfix/main.cf I added

virtual_alias_maps = hash:/etc/postfix/virtual proxy:tcp:

In /etc/mailman/mm_cfg.py I added

MTA = ‘Postfix’

Next was

#nano /var/lib/mailman/data/virtual-mailman, I added

test@xxx.de test@localhost

Then I run

#postmap /var/lib/mailman/data/virtual-mailman
#postfix reload
#systemctl reload mailman

Of course I added the service mailman inn NS first.

Guess what - running now.

Probably not surviving the next update… Should be templated I guess. Anyone hopping on? I did templating a long time ago, I’m not the champ in this.

Maybe it helps someone.



Forgot to mention to add in /etc/aliases the config of the mailing-list. Looks like this:

##test mailing list

test: “|/usr/lib/mailman/mail/mailman post test”
test-admin: “|/usr/lib/mailman/mail/mailman admin test”
test-bounces: “|/usr/lib/mailman/mail/mailman bounces test”
test-confirm: “|/usr/lib/mailman/mail/mailman confirm test”
test-join: “|/usr/lib/mailman/mail/mailman join test”
test-leave: “|/usr/lib/mailman/mail/mailman leave test”
test-owner: “|/usr/lib/mailman/mail/mailman owner test”
test-request: “|/usr/lib/mailman/mail/mailman request test”
test-subscribe: “|/usr/lib/mailman/mail/mailman subscribe test”
test-unsubscribe: “|/usr/lib/mailman/mail/mailman unsubscribe test”

@schulzstefan the first edit at email parameters on Cockpit could destroy your manual edit.
Consider to create a configuration fragment to make your changes permanent.

This is the only templated file I found so let’s add a custom template fragment:

Create dir:

mkdir -p /etc/e-smith/templates-custom/etc/postfix/main.cf/

Create template fragment /etc/e-smith/templates-custom/etc/postfix/main.cf/90mailman with following content:

virtual_alias_maps = hash:/etc/postfix/virtual { ($postfix{DynamicGroupAlias} || '') eq 'enabled' ? 'proxy:tcp:' : '' } hash:/var/lib/mailman/data/virtual-mailman

Apply the config:

signal-event nethserver-mail-server-update


Thank you for helping with this.

Best regards and a merry christmas to everybody.


1 Like

Something is still wrong or not quite correct/complete.

As I told above for testing purpose I created a user test. Remember, the list “test” was already there. Later on I deleted this user and it was possible to send an email to the list “test”.

Today I tried to send an email to a list called “christmas”. That didn’t work out. Here’s the snip from the maillog:

postfix/lmtp[7969]: 67A9695F4F: to=christmas@localhost.yyy.de, orig_to=christmas@yyy.de, relay=xxx.yyy.de[/var/run/dovecot/lmtp], delay=0.41, delays=0.17/
0.03/0.05/0.16, dsn=5.1.1, status=bounced (host xxx.yyy.de[/var/run/dovecot/lmtp] said: 550 5.1.1 christmas@localhost.yyy.de User doesn’t exist: christmas@localhost.yyy.de (in reply to RCPT TO command)

I created a user named christmas. I sent an email to the user/list christmas. The mail was delivered in the local postbox of the user christmas. Afterwards I deleted the user christmas.

I followed the steps described in post (3) and did also a #:newaliases

Now it worked. The email went to the list christmas. And mailman worked flawlessly the appx. 2500 emails from the list out.

I assume the reason could have to do something with dovecot, but this is beyond my knowledge.

This is just to let you know, I can live with that.


1 Like