NS 7.9.2009 - Shared folders - Access denied

NethServer Version: 7.9.2009
Module: File Server

Hello there,

Hope someone could help with this issue I am having with NS

Short description of the issue
Unable to access shared folder, permission denied. Searched in the forum and could not find the solution for the issue. Tried with different owning group and guest access with no luck.

Oveview of the server setup
Netserver is virtualized on a Zorin Lite Host using virtualbox. NS is configured as AD, DNS and file server. A 500GB drive is mounted to virtualbox shared folder which is then mounted in the NS folder /var/lib/nethserver/ibay

Log error message
Noticed the following error in /var/log/messages each time I tried to access shared folder,

Any help will be much more appreciated

Can you check the permissions on /var/lib/nethserver/ibay/ ?

This the current permissions

vboxsf is a group you created in Samba?
Did you allow promiscuous mode for your network adapter in VBox?
What I can think of, is you try to use SMB1 to connect while it is deactivated.
@support_team

I think the virtualbox shared folder is the problem, it seems only designed for simple file copies between host and guest. It sets access permissions for vboxsf group. Neth users are not member of this group and therefore cannot access the share.

Permissions should look like this:

[root@server2 ~]# ls -ltr /var/lib/nethserver/ibay/
total 0
drwxrws--- 3 root domain users@ad.domain.local 42 May  7  2020 test22
drwxrwsrwx 6 root service@ad.domain.local      70 Sep 28 10:20 backup
1 Like

Thank you @ mrmarkuz, that was the issue. Workaround is to add extra disk to vbox instead of a vbox shared folder.

Merry Christmas and happy new year to Nethserver Community.

1 Like