Notes from migration from Zentyal 3.2

Last few days I have been busy migrating 2 Zentyal 3.2 servers, (based on Ubuntu 12.04 LTS) to NS 7RC3.

I took the ‘easy’ road and only backupd up the data on the shares. The users were recreated on NS since there are only 6 users on my own server and only 3 users on the other server I migrated. There were no webbased applications with data that needed to transfer to the new install.

Both servers are running on an HP gen7 microserver with a single disk for /, /boot and swap and a software raid1 for data. Besides the default hardware, both servers had an additional 2port Intel Gb network adapter and 4GB RAM instead of 2GB.

Since I had both servers at my home, I could start with copying the data from 1 server to the other. I created a share called backup. On Zentyal the samba shares live in /home/samba/shares.
With the following command I copied all data recursively with preserving timestamps:

scp -rp /home/samba/shares/* rob@:/home/samba/shares/backup/

I created a bootable NS7RC3 USB disk using dd:
First use “fdisk -l” to find the USB device
Make sure the USB device is unmounted:

umount /dev/sdb

where sdb is the name you found using fdisk -l command

sudo dd if=/path/to/NS7.iso of=/dev/sdd

where if is input file and of is output file.

When the USB stick is ready, you can reboot your server and boot from the USB stick. You will be promptyed with the NS7 splash screen. Go with the first choice: interactive install
I will not describe the specifics here, since there are several howto’s for installing NethServer available.

I noticed a few things:
After reboot the dualport Intel Gb networkcards were not configured properly. Although I gave them a specific IP address. I solved this by using the onboard broadcom network adapter and checked what IP that had. Set a static IP on my laptop and could access the server manager. From servermanager I was able to change the network settings for the 2 ports on the Intel network card.

I installed fileserver module. What I noticed is that you can not use groups as ACL. You have to use add a user to the ACL tab of the shares you create.

1 Like

Do you remember if the network cable was plugged in during install?
Is there a DHCP server in your home network which could have given an ip during install?

Hi @filippo_carletti
Yes there was a DHCP server active, but if I set a static IP I just don’t understand why the interface doesn’t gets configured that way.
Only 1 of the ports was connected with a cable.
The 3rd interface (the onboard broadcom network interface) was unconfigured and unconnected during install. When I plugged in a cable and restarted the server, it came up with an IP address in a complete different subnet: while my network has as external subnet and as internal subnet.
To reach the server I set as static IP address on my laptop and could connect to server manager. From server manager I could configure the other 2 interfaces.
IMO a weird situation, but I could work around it.

That’s the bug I’m chasing.

Hi @filippo_carletti
Any updates on the interface config bug? I re-installed a HP G7 microserver with the dual Intel Gb adapter and again I ran into the same situation that configured settigns were not set. I could access the onboard interface since it was set at, but where that IP address came from I don’t know. I am not using addresses in that subnet on my network.

I think that is a fallback address hard coded in the install procedure. I’ll have to check the code, maybe I’ll ask @giacomo.
If your bug is the same I had, you have to reboot the system again after first boot (I search log lines about system-init in /var/log/messages to be sure initial configuration is completed).


@filippo_carletti I was busy creating a screencast about installing NethServer7RC3 in Virtualbox and I encountered the same behavior with the ‘Host-only’ adapter. The Host-only adapter (vboxnet0) is not configured after initial install.
The adapter bound to ‘Bridged’ adapter to the physical adapter of the host is getting configured correctly.

1 Like

Wow! I can’t wait for it

It will be part of the NS course. I will be publishing the video later this week.