Not everybody is comfortable with CLI


(Gabriel GHEORGHIU) #1

Zentyal yes, Ubuntu server as request.
On Zentyal you can make all interventions/settings from that server/machine. It is not about actual webgui. It is possible that you can’t connect to the server, and not everybody (like me) is comfortable with CLI.


My wishes list (or Letter to Santa)
My wishes list (or Letter to Santa)
Community Digest 6 - October 2015
(Stefano) #2

sorry but…

dealing with a linux system can’t be done without knowing hot do debug/config/repair it via CLI…

if for any reason the admin web server can’t start, you’d be able to find the reason and to repair it…

otherwise we are sysadm “a la windows”…


#3

And what about Moonwall, Pfsense, FreeNAS, Nas4Free, OpenMediaVault, ClearOS?

There’s a path between the CLI way and the “a la windows”


(Stefano) #4

they are useless without their gui… BTW, if a ssh daemon is available, it’s enough…


(Bogdan Costin) #5

@zamboni Sorry Stefano but this is just nonsense.
This was true in '97 when i had the slackware distro and no support for Gui. Now in this time and edge the GUI is necessary.

I have seen that almost every post you make you bring up the CLI vs GUI topic…
It is pointless in my opinion. I understand that you like CLI but it is not the “universal” way. I like GUI and WebUI. and that’s that. I do not think that you or anybody else would like to have the same rambling about how GUI is wonderful or how we should use all the (Gui/Web) UI.

I use any UI that suits me in that moment.

Please stop with this CLI / GUI/ WebUI discussion since it is not adding any value to the discussion.

PS (we can discuss further on this topic if you want on private or IRC)

Best regards
Bogdan


(Bogdan Costin) #6

Yes it is but it is not accessible for everyone.
No matter if you have a cli available if you use NS is because it was simple to use and manage.
At least this is the purpose of NS.

I agree to some point that Desktop is useless for NS but we are trying to make NS easier not to make the users learn *NIX.
If they have some knowledge about *NIX is better but it should not be Mandatory! IMHO.

Do not read me wrong. If you have some doubts about what i wrote please ask.

BR
Bogdan


(Stefano) #7

and I repeat… web GUI just mimic/is an interface of internal commands

I am not against a web GUI at all.

you don’t need to know how linux works inside, you just need to know how to call internal commands from CLI and to deal with log’s digging

finally, making things easier and easier makes users dumb and dumber… and that’s bad if you publish your server on WAN (and this is another fact, see M$ for reference)


(Davide Principi) #8

Have you ever tried elinks with NethServer? I’m quite sure a lot of Server Manager pages work even without JS.


(Bogdan Costin) #9

Hi Stefano
I agree, the users are not skilled anymore…
This does not mean that they are dumb. :smile:

They (any of us) have other priorities in life. And having NS more and more accessible will attract the users that have less and less knowledge on how stuff works.
This is NOT a bad thing.

The purpose of technology is to make our life easier.
To have a Gui does not mean that we disable CLI. This is not like the M$ world :smile: It will be available to skilled users and to users having trouble with the UI.

But keep in mind what is the primary goal of the NS. To make Netserver accessible to anyone in need of a server.

As a note. I do all the tweaking via ssh and this doesn’t mean that i do not focus all my attention on G/WUI.

Let the more technical users use what they want. Do not force the less technical to use the CLI. They will surely make a mess. If they really want to learn they will. Otherwise it will do more bad than good.


(Stefano) #10

you can’t even login in web GUI using elinks
moreover, elinks is not installed


(Bogdan Costin) #11

Try " lynx https://ip-addr:980" then confirm the certificate trust and it works :smile:


(Davide Principi) #12

IIRC elinks has a basic JS support, thus must be disabled with Server Manager


(Stefano) #13

I use elinks since epoch… it doesn’t work with NS


(Stefano) #14

can you give me some hints on how to disable it? I din’t find anything


(Bogdan Costin) #15

It works with elinks too:


(Stefano) #16

interesting… I just can’t login… the auth form doesn’t work


(Bogdan Costin) #17

Does it display the login form or just hangs ?

Try using lynx just to get the certificate, then try with elinks

elinks has a strange way of using the fields in a form…


(Stefano) #18

no problem with the certificate…

It only shows me the form, I had to disable all keyboard binding… but still doesn’t work…

will dig it another day


(Davide Principi) #19

In elinks.conf manpage there’s ecmascript parameter


(Stéphane de Labrusse) #20

A GUI is resource consuming and has no interest for debugging purpose, but I agree that people are more confident with it. I would be more interested by an ajax/JS/nm terminal in the server-manager. The most of time you need to copy and paste a command line.

I don’t need it, so I’m not interested by it…sorry :smile:

Concerning the idea to update the system during the installation or offer to install some Neth roles directly, it is good, but I worry on the skill and the work needed, anaconda needs to be modified.