None of the Apps works - no virtualhost can be accesed

NethServer Version: latest stable
Module: mattermost, webtop, and of course webserver

I have a fresh install but nothing works as expected, hostnames dont relsolve, not setup wizard popping up for mattermost, letsencrypt certs are issued but dont work… horrible.

Any idea? I have done un-reinstall of the apps nothing changed. Really, I give this a try but it has to work like 1, 2, 3, whitout going into deep inspection. There must be a reasable answer to all this.

Thank you, Peter


Good Morning Peter

And Welcome to the NethServer Community!

Just by reading your problem, no details provided:

  • Your NethServer is running with 2 NICs as Firewall?

I’d say your NICs are set wrongly in regards to GREEN and RED…

But a bit more info as to your situation would help!
Stuff like native Install (not virtualised), running as firewall with 2 NICs (or not), amount of RAM in Server, environment (another router/firewall to internet)?

My 2 cents


hi, its standard cloud instance… 4 gig ram, 2 nics in red and green, lan/fw, fresh install… nothing works. as i said, it has to work 1,2,3 out of the box whitout deep inspection. otherwise its worthless. maybe to metion, there is nothing in front of it, i run some more servers beside, pfsense, centminmod and other centos 7 instances… nethsever is just an experiment.

Best, Peter


Maybe you need to try this:[]=dummy

I had only one NIC available with only one IP from the hoster. With the instruction it worked, even for VPNs. (OpenVPN and IPsec).

I suppose / assume you started with a standard / minimal Centos / and installed NethServer over that? AFAIK, only DigitalOcean offers NethServer directly.

What are you using for LAN IP, if it’s in the cloud?

If possible, send a screenshot how the NICs are configured (RED & GREEN).

Can you access it via the dashboard or the newer cockpit?


1 Like

Thank you, Iv shout it down, powerd up a new centos instance, did some configs and now i have a working kopano mailserver. will look into it again in 6 moths… for sure some check routines are not in place for now. A prodeuct has to deliver, 1, 2, 3. otherwise its past years I haved sme server, koozali, e-smith and finally mitel. Nethserver is not mature yet, missing quality check. not all people like to go into deep inspection, as said … it has to work out of the box like 1, 2, 3.

Best, Peter

Hi Peter

It does work 1, 2, 3 for all the rest of us here…

Good luck!

I’m sorry, but that’s simply an idiotic a nonsensical expectation of any piece of server software*. You set it up incorrectly, likely without reading the documentation, and you’re blaming the software. It’s 99% likely that the problem is 100% on you. As it is right now, you’ve wasted your time and ours–yours in whatever time you’ve put into it that didn’t result in a working system; ours in the time responding, gaining no understanding of what the problem actually was since you’ve given us absolutely nothing to work with, and we can’t do anything to make it any better because all you’ve done is complain.

*your requirement boils down to “it’s literally impossible to misconfigure it.” That isn’t true of CentOS, it isn’t true of Koozali/SME (and the order you put those in is, well, weird–it’s been ages since Mitel had anything to do with it as a standalone product), and it isn’t true of any other piece of software less trivial than Hello World. If it can be configured, it can be misconfigured. And nobody can build a foolproof product because fools are so damned clever sometimes.


you absolutely right…

after some time, and the efforts put into it by you devolpers… it works as expected. Nearly, 1,2,3 :wink:

If you know what to do (maybe after reading documentation and make thing works in your mind) it’s always nearly 1, 2 ,3