No mirrors for "centos-base" and for "centos-updates" repositories


After the last update to CentOS 6.8, I have observed that in mirrorlist there are no mirrors for “centos-base” and for “centos-updates”.

Before the update to CentOS 6.8, there were mirrors for CentOS (please see the attached files), from Romania. I think there may be an issue with romanian mirrors.


  • What and where I must modify to have mirrors for “centos-base” and for “centos-update”, but not from romanian mirrors (I prefer mirrors from US).



Maybe the update policy is changed?
Will be available updates only through NethServer, including CentOS updates?

version mismatch?

# cat /etc/centos-release
CentOS release 6.8 (Final)

# cat /etc/yum/vars/distroversion


# cat /var/cache/yum/x86_64/6/centos-base/mirrorlist.txt

same as
but compare it to

Possible fix? (to test on non-production server)

# echo 6.8 > /etc/yum/vars/distroversion
# yum clean metadata
# yum update

Thank you Marc,

It works!

The versions were good.
The upgrade to NS 6.8 was OK but there were no mirrors for CentOS updates/upgrades.

After “Possible fix? (to test on non-production server)”, tested first on VM * and then on production server, I have mirrors (please see the attached files).

  • I had the same issue on VM: I had a NS 6.7 “virgin” and I tried to update it to NS 6.8 from “Software center”. The update worked only for NS, not for CentOS which remained to 6.7, and no mirrors for CentOS in Software center.

Thank you again!

Kind regards,

1 Like

I was thinking why we got the vault link. Not very familiar with CentOS but suspected it is to archive old unmaintained releases.

Checked a CentOS mirror and got this:

This directory (and version of CentOS) is deprecated. For normal users,
you should use /6/ and not /6.7/ in your path. Please see this FAQ
concerning the CentOS release scheme:

If you know what you are doing, and absolutely want to remain at the 6.7
level, go to for packages.

Please keep in mind that 6.0, 6.1, 6.2, 6.3, 6.4 , 6.5, 6.6 and 6.7 no longer gets any updates, nor any security fix’s.

So it seems there were no mirrors cause the 6.7 branch was moved to vault. That is normal behaviour:

Did not test it, but maybe the distroversion variable should be 6 instead.

Is this something we need to take care for future releases? Should the nethserver-release.spec file be modified?


Hi Marc,

There was a discussion about this, here:

Software Center & yum Error

In this case (my case but I saw also and in other printscreen in this topic, @fasttech, that there are no centos mirrors), I think it was only a matter of yum cache which was solved with the last two commands:

yum clean metadata

yum update

1 Like

Thanks for the link!, missed that.

In this case, I tested with just those two commands, and also tried with yum clean all (and done some other tests), and there were still no centos mirrors. But changing the version number (directly in the mirrorlist like @giordy kindly suggested or the distroversion var) succeeded.

If this is a measure to prevent updates from breaking the system, that’s OK. But then IMO the nethserver package updating to a new release should take care of this as well. Otherwise, if no major risk, use just the major version number.

OK. There’s something related in the commits:

1 Like

I put myself the same question but I guess it is only a minor programming problem (something is not working well or not correlate properly).


I saw your EDIT after my reply …

We did some work on mirror list, but we didn’t found any problems.
I will check it tomorrow

1 Like

You can edit the exclude/include sections of the /etc/yum/pluginconf.d/fastestmirror.conf file.


Sorry @GG_jr, didn’t recall correctly. See my edit.

1 Like

I did this on Zentyal but here is a little bit different.

Anyway, now it works and I know that is not about the romanian mirrors.
I saw in /etc/yum.conf that is possible to refresh metadata from time to time but I will not change anything for now.

I will wait to see what Giacomo would say after he will check.

1 Like

The updated policy is still the same:

  • CentOS packages always from upstream repositories
  • NS packages from NS mirrors

But we noticed that CentOS did some changes to the mirrorlist behavior, but it should be fixed.

The update process should be transparent.

From the web interface:

  • Click the update button, a new nethserver-release will be installed which points to the new repositories for 6.8
  • When the yum cache will expire, new updates will be available from the web interface: all new packages from NS 6.8

From the command line, the process is:

 yum update
 yum clean all
 yum update 

We already changed this behavior: from 6.8/7.2 the update will be a simple “yum update” (or a single click on the update button in the Web Interface).


Your commands are correct for me. What happens when nethserver-release-6.8 RPM is installed is very similar to those commands:

  • /etc/yum/vars/distroversion is updated
  • yum metadata are NOT cleaned immediately, but are going to expire in 6 hours
  • yum update will be called next time user press “Update” from Software Center page

Thanks for explaining the process and what triggers it. :slight_smile:

A post was merged into an existing topic: Install failed due to metadata caching issues

Weird, I had upgraded a couple of production installs to 6.8 final, completed upgrades, I thought, until I saw that one had old packages, and no centos caches, a yum clean all fixed that and now there’s a flood of updates. Sigh, thought I was done at that office.