No internet connection and network card turned off during installation

NethServer Version: 7.9.2009

Hi guys, how are you?
I hope you’re fine I am a little desperate.

I’m trying to install NethServer using graphical mode: first time everything was ok and there were no problems.

Unfortunately I had to do a clean install again and there the problems began.
I know that if all works as it should when you choose options internet should be already connected thanks for DHCP.

But 90% of the time there was no connection (but network was perfect, I tried to change cables and reboot switch, router, … ) and if I set a static ip address (and toggle the network card switch) seems connected: but it isn’t! If I disconnect cable nothing change.

I tried to install anyway but server is always offline and can’t ping router (or others).
I have found that sometimes the RJ45 port has LED lights turned off.

Finally I tried to make the USB in several ways: Balena Etcher and dd command but situation is the same.

Uff … (Thanks :slight_smile: )
Pellegrin A.

Mh … ok, seems like this: Linux sysadmin basics: Start NIC at boot

If i use:
sudo ifdown enp4s0
sudo ifup enp4s0

internet works, but if i reboot everything is cleared.


Would you please share the chip of your “troubled” NIC?

After you if-up if you go into the GUI and setup the nic in there save and restart does it still revert to no nic up on reboot

@andreapellegrin would you please share more info about your network card?
Brand, model, speed, separate card or integrated into which mainboard?