No image with Transparent proxy

NethServer Version: 7.5.1804 (final)
Module: your_module

Hi All,

enjoying the Transparent proxy feature with NS , however there was some issue when users connect to Facebook or Youtube.

Sometime and randomly some user cannot view any image when accessing to those website, for Facebook still can view page post, Youtube can view the video, but both cannot view any image,

Please help,


Hi All,

on the /var/log/squid/cache.log i got alert log as below image.

And on the administration guide of NS also mentioned that this kind of issue can’t be fixed +_+!
Any advise please,


Do you use the web content filter?
If so, the images could be blocked by some categories.
Have a look at


at the time you try to open youtube and facebook and whitelist the ads you see at the log at this time.
For more assistance don’t be shy to ask

Host header forgery messages usually appear in log when NethServer is not used as DNS server by the clients.

1 Like

Hi m.traeumner,

No, i did not enable the website content filter.
also i tried to enable and add and to global white list, the image also cannot load.


Hi filippo,

Yes, our client set DNS to our local DNS server.
I also tried to set the DNS of NethServer to local DNS server (as client) but not success.

The strange is sometime it can load the image, sometime not.


No, it’s “normal”. When the URL is resolved to the same address in the client and in NethServer there’s no forgery and the image is displayed. When the IP is different, squid on nethserver blocks the request.
The problem happens only on websites that have multiple ip, such as google, amazon ,etc.

1 Like

Here is my whitelist for youtube:

At first I would try to whitelist

I see, thanks for your clearly explanation.
So do you have any suggestion for this case ?


As fllippo’s explanation above, seem like this is transparent proxy’s behavior, not blocked by website content filter.

Thanks m.traeumner

Is there a workaround?

1 Like

Hi All.,

Any help or advise please ?
I did upgrade the Squid version but no luck.



That’s the problem. With version are you running? How did you upgrade it?

HI filippo,

I did downgrade to 7:3.5.20-12.el7 and tested, but fail
Then i upgrade and now running on 7:3.5.20-999.ns7


Your squid-3.5.20-999.ns7 is the right version. You should not experience problems now.

Hi filippo,

Unfortunately the issue still there. images not loaded when access to randomly.
I did tried to bypass domain but nothing changed.


If helps, some info from squid’s wiki:

Hi dnutan,

thanks for your sharing.
i did follow all workaround in that post, but no luck !!!

Any other workaround should i try. not sure the reason but now the access to FB is normal, all image can seen, but still have issue with youtube


Just to be clear:
the squid package distributed with NethServer disables the Host Header Forgery check.
Well, the check is still in place but generates only a log entry without blocking the navigation.