No applications listed in Software Center after install

Well, that was interesting. I did as @greavette suggested and bingo, I have the applications listed now. I did see a bunch of error mss scrolling, though: the gist of them being repeated “Network is unreachable.” And ending with “No packages marked for update.”

Not sure what exactly happened with all that, but the apps are there, and I thank you!

1 Like

Happy to hear it worked out for you @davidx.

Welcome to Nethserver! :slight_smile:

PS. May as well as mark this topic as solved if you are good to go.

1 Like

Whoops, spoke too soon!

Went down the list checking off apps to install and then it all disappeared and I’m getting the red warning box to “CLEAR YUM CACHE.” I do that, and it just keeps popping up anyway.

The full mss:

“The install/update may have failed due to metadata caching issues. Please clean the cache by clicking the button below and retry the install/update operation.”

Failed again.

Tried the “Updates” tab and I get this:

(RepoError) Cannot find a valid baseurl for repo: nethforge/7/x86_64" And then the same “install/update” failure message and advice to clear the yum cache.

So I still can’t mark the topic as solved, sorry to say, but many thanks for helping.

Hi @davidx, let’s see what more I can do to help here…

Try issuing this command from the command line (again putty):

yum clean all

Then do an update again from the command line:

yum update

I always give my nethserver a reboot for good measure.

Report back with what happens.

Same CLEAR YUM CACHE warning.

Doing yum update gets me:

“Could not retrieve mirrorlist…etc.”

“14: curl#7 - Failed to connect to Network is unreachable.”

“One of the configured repositories failed (Unknown)”

“…and yum doesn’t have enough cached data to continue. At this point the only thing that yum can do is fail.”

And there follow five suggestions to “fix” this.

I rebooted Nethserver itself several times and the CentOS server likewise.

Interesting little problem…

Hmmm, did you first clear the yum cache? What did the response say after clearing cache was completed?

Are you sure you have access to the Internet? Try pinging Google to make sure you get a reply.

Yes, cleared the yum cache but it keeps popping up anyway.

Something is off here;

Pinging Google gets me: “Network is unreachable.”

Yet I can use Firefox to connect to Nethserver or anyplace else.

I must be stupidly missing something…

Network is unreachable will cause you errors with yum update for sure. Check your network/firewall/router to make sure you aren’t blocking your Nethserver from Internet access. What is your network topology? What are you running your Nethserver in (physical or virtual)?

Your early in your setup so if this is a VM maybe blow away this install and start over.

Nethserver 7.3 running on top of CentOS 7.3, and connecting to the former (https://my IP:980) via Firefox with no problem. But running yum update is somehow an issue.

The CentOS machine itself is connected via Ethernet to the router, as is a Linux Mint desktop in the same room. And there is no problem with it connecting to anyplace on the internet. But yum update doesn’t work.

So just to be clear…you’ve downloaded the Nethserver ISO version 7.3 and installed it on a physical server that is connected to your router.

I’m curios what your result of

yum repolist -v

I don’t understand your comment about not having trouble connecting to anywhere on the internet. Is this comment related to your other linux machine in the same room? What is that linux mint server installed on?

Followed the instructions on the docs page for setting up the repo and then doing “nethserver-install” accordingly and all went well until I tried to use the Software Center. So it’s Nethserver 7.3 running on a CentOS 7.3 server, which can otherwise connect to either https://xx.x.x.xx:980 or any other site via Firefox. But when I try yum update I get the “unreachable” errors and likewise when I try to ping

So, right now, I can get to any site using Firefox on the CentOS 7.3 server. But at command line, I can’t even ping google.

yum repolist -v:

Same result as “yum update.” Starts to list some things, and then becomes “unreachable” with a list of suggestions to “fix” it.

The other machine in the same room is also connected to the same router and the internet and is a Linux Mint 18 desktop. Nary a problem there.

I think I’m missing something really obvious here but don’t know what it is: how is it that I can use Firefox on the CentOS box to connect anywhere on the net, but in the command-line, I can’t even ping anybody?

Ok now I understand your setup. I personally wouldn’t install Nethserver this way. Download the ISO and install it from there…much easier in my opinion. The Nethserver team has created a pretty awesome system from their ISO.

You’ll probably need someone more experienced than me from the @dev_team to help you fix your system as it now stands…but in my opinion I would blow away this server and reformat to install Nethserver from ISO.

If you are testing Nethserver why not install Nethserver in a VM. I use my Nethserver in a VM and I’ve been saved a few times when I’ve had to restore from backup after I’ve made a mistake.

I hear you loud and clear.

Debating with myself what to do now:

1.) Blow away Nethserver entirely from the CentOS machine and install the latest stable .iso in a vm on it.

2.) Blow away Nethserver entirely on the machine and install the latest stable .iso on another, bare-metal machine accordingly.

Probably sleep on it tonight. Thanks so much for your help and plugging away with me on this; much appreciated.

I would try a virtual machine install. Use only one Nic on the VM as you probably need the green interface.

But lets wait till others more versed in Nethserver than I look at this thread and provide their helpful assistance.

Did you set a gateway?

Please paste here the output of

db networks show
1 Like

Can you check your network settings first and if necessary, configure them so you have a network connection (and ultimately an Internet connection)?
Then do the yum update again.
I have seen the red clear cache warning when there was no Internet connectivity to NethServer.


Reinstalled CentOS 7 from scratch but I get the impression that working from the instructions on the doc page is not desirable? i.e., command-line downloading of the repo and then “nethserver-install” and so on? I tried that before and got all the way to the Software Center where I couldn’t do anything further.

And I’d not had network connection problems prior to doing all that, and after that, the CentOS machine could at first get to the net via Firefox but not the command line (ping), and then not at all.

I’m hesitant now to go any further; installing it in a vm doesn’t look like much fun, either. Anyone done that on CentOS or RHEL yet?

Update: Just tried setting it up as a vm under VMware Workstation 12 Pro and no dice. Wouldn’t do it via qemu, either.

My preference is to use Proxmox on a dedicated server…but for sharing try Virtualbox:

Thanks for the link. Went through the whole process and still no joy in Mudville. VirtualBox would not install, googled possible solutions to no avail.

At this point, three different vm methods have been tried to no avail.

The “normal” install method from the online Docs apparently won’t work, either.

And now I have some leftover crud I have to clean up, I guess.

Thanks for helping out but it looks like Nethserver 7 is no-go here.



If you have something like pfsense sitting between your network and the internet with suricata installed, then i would check the logs, to see if yum traffic has been blocked. Otherwise what @davidep said, setting the gateway and external DNS is usually an error on my side.
Also what comes to my mind is possibly an ip conflict on your LAN. I have a box, where if i install NS in interactive mode, and set a static IP address, for some reason, by the end off the installation it always changes to the same ip address like my gateway has, rendering both unaccessable after a few minute.

1 Like