No access to Owncloud WebDav


(Nikolaos Risvas) #1

Hello everyone,
as i’m new to nethserver i’ve faced yet another problem.
I have owncloud up and running correctly through https (although i still have the problem of it not redirecting to https from http).
If i try to connect to webdav either through some android app or bitkinex on windows it won’t connect.

In bitkinex it says: HTTP: Method Not Allowed (/) and won’t show me anything and on the app it simply says can’t establish connection.

I believe it might be connected to owncloud not redirecting HTTP to HTTPS but i’m not sure and also jabber has the same problem, no connection can be established to it either.

Here is my forum post about the http to https connection problem: ("Redirect" HTTP to HTTPS)


(Artem Fedai) #2

Hi please share httpd access and error logs.


(Nikolaos Risvas) #3

Access Log:

127.0.0.1 - - [08/Mar/2016:11:41:45 +0200] “GET / HTTP/1.0” 403 4961 “-” “check_http/v1.4.16 (nagios-plugins 1.4.16)” 192.168.1.7 - eva [08/Mar/2016:11:41:57 +0200] “PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1” 207 2252 “-” “Mozilla/5.0 (Windows) mirall/2.1.1” 192.168.1.11 - pav-security [08/Mar/2016:11:42:06 +0200] “PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1” 207 9229 “-” “Mozilla/5.0 (Windows) mirall/2.1.1” 192.168.1.7 - eva [08/Mar/2016:11:42:27 +0200] “PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1” 207 2252 “-” “Mozilla/5.0 (Windows) mirall/2.1.1” 192.168.1.11 - pav-security [08/Mar/2016:11:42:36 +0200] “PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1” 207 9229 “-” “Mozilla/5.0 (Windows) mirall/2.1.1” 192.168.1.7 - eva [08/Mar/2016:11:42:57 +0200] “PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1” 207 2252 “-” “Mozilla/5.0 (Windows) mirall/2.1.1” 192.168.1.11 - pav-security [08/Mar/2016:11:43:06 +0200] “PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1” 207 9229 “-” “Mozilla/5.0 (Windows) mirall/2.1.1” 192.168.1.7 - eva [08/Mar/2016:11:43:27 +0200] “PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1” 207 2252 “-” “Mozilla/5.0 (Windows) mirall/2.1.1” 192.168.1.11 - pav-security [08/Mar/2016:11:43:36 +0200] “PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1” 207 9229 “-” “Mozilla/5.0 (Windows) mirall/2.1.1” 192.168.1.7 - eva [08/Mar/2016:11:43:57 +0200] “PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1” 207 2252 “-” “Mozilla/5.0 (Windows) mirall/2.1.1” 192.168.1.11 - pav-security [08/Mar/2016:11:44:06 +0200] “PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1” 207 9229 “-” “Mozilla/5.0 (Windows) mirall/2.1.1” 192.168.1.7 - eva [08/Mar/2016:11:44:27 +0200] “PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1” 207 2252 “-” “Mozilla/5.0 (Windows) mirall/2.1.1” 192.168.1.11 - pav-security [08/Mar/2016:11:44:36 +0200] “PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1” 207 9229 “-” “Mozilla/5.0 (Windows) mirall/2.1.1” 192.168.1.7 - eva [08/Mar/2016:11:44:57 +0200] “PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1” 207 2252 “-” “Mozilla/5.0 (Windows) mirall/2.1.1” 192.168.1.11 - pav-security [08/Mar/2016:11:45:06 +0200] “PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1” 207 9229 “-” “Mozilla/5.0 (Windows) mirall/2.1.1” 212.251.48.182 - - [08/Mar/2016:11:45:21 +0200] “PROPFIND / HTTP/1.1” 405 226 “-” “BitKinex/3.2.3” 192.168.1.7 - eva [08/Mar/2016:11:45:27 +0200] “PROPFIND /owncloud/remote.php/webdav/ HTTP/1.1” 207 2252 “-” “Mozilla/5.0 (Windows) mirall/2.1.1”

Error Log:

[Tue Mar 08 10:41:45 2016] [error] [client 127.0.0.1] Directory index forbidden by Options directive: /var/www/html/ [Tue Mar 08 10:46:45 2016] [error] [client 127.0.0.1] Directory index forbidden by Options directive: /var/www/html/ [Tue Mar 08 10:51:45 2016] [error] [client 127.0.0.1] Directory index forbidden by Options directive: /var/www/html/ [Tue Mar 08 10:56:45 2016] [error] [client 127.0.0.1] Directory index forbidden by Options directive: /var/www/html/ [Tue Mar 08 11:01:45 2016] [error] [client 127.0.0.1] Directory index forbidden by Options directive: /var/www/html/ [Tue Mar 08 11:06:45 2016] [error] [client 127.0.0.1] Directory index forbidden by Options directive: /var/www/html/ [Tue Mar 08 11:11:45 2016] [error] [client 127.0.0.1] Directory index forbidden by Options directive: /var/www/html/ [Tue Mar 08 11:16:45 2016] [error] [client 127.0.0.1] Directory index forbidden by Options directive: /var/www/html/ [Tue Mar 08 11:21:45 2016] [error] [client 127.0.0.1] Directory index forbidden by Options directive: /var/www/html/ [Tue Mar 08 11:26:45 2016] [error] [client 127.0.0.1] Directory index forbidden by Options directive: /var/www/html/ [Tue Mar 08 11:31:45 2016] [error] [client 127.0.0.1] Directory index forbidden by Options directive: /var/www/html/ [Tue Mar 08 11:36:45 2016] [error] [client 127.0.0.1] Directory index forbidden by Options directive: /var/www/html/ [Tue Mar 08 11:41:45 2016] [error] [client 127.0.0.1] Directory index forbidden by Options directive: /var/www/html/ [Tue Mar 08 11:46:45 2016] [error] [client 127.0.0.1] Directory index forbidden by Options directive: /var/www/html/


#4

Hi, what type of client are you using? The owncloud client app or a webdav navigator?

Your android client try to connect to Owncloud, but how?
is connected by wifi on the lan side or is connected by your phone provider ( by the wan side).

Edit: tipography corrections…


(Nikolaos Risvas) #5

I tried bitkinex from computer using windows 10.
On android i tried the ACR app which backups files through webdav.
ACR used to work correctly on my previous setup which was Ubuntu server and owncloud installation which i made on my own.
The phone was connected through carrier network. The computer is on the lan but i can’t connect using either the domain name or the local ip address of the server.
The owncloud app connects correctly both on computer and android.


(Alessio Fattorini) #6

Which version of owncloud did you have on your Ubuntu?


(Nikolaos Risvas) #7

It was version 8, not sure which minor version exactly but i always updated it when the latest version came out.