Nginx upstream timed out


Is it possible to maintain this op tion in ns-ui.conf ?
I have a lot of there errors in the log
nethsec8 nginx: 2024/05/17 21:39:20 [error] 17791#0: *1999 upstream timed out

To solve this i need to add this to ns-ui.conf
proxy_read_timeout 120;

But get overwritten by an update

Not really.

This is quite strange, I do not see any error like this on my production machine.
Are you sure that errors are referring to ns-ui and not to a proxypass?

It is refering to my ClearOS server.
I’ve still have my mail server running on COS and the errors are linked to the active sync

I’m using the reverse proxy to link to this server
With Nextcloud i don’t see these errors and this is running on the same server

I was wrong, you can do it with these commands:

uci set nginx.ns_6664f081.proxy_read_timeout=200
uci commit nginx
/etc/init.d/nginx restart

Replace ns_6664f081 with the id of your reverse proxy.


Can i check somewehre if this setting is still active.
I’m still seeing these errors and want to check if this setting is functional

You can check the config with:

nginx -T -c /etc/nginx/uci.conf

Found it and the line is in the configuration for the correct domain.
Unfortunately is is not solving the errors