NFS, CIFS backup

NethServer Version: 7.9.2009
Module: Data backup (Default module for backup)

It’s been hours since I can’t figure out how to fill in the fields correctly to run a backup. The computer is logged into the domain, there is a VPN connection to it. The server is pinging it.

Please help.

For NFS I write like this:
NFS Share: - I have also tried \\net

For CIFS I write it like this:
SMB Share: - I’ve also tried \\net.
SMB Login: administrator - this is the login of the domain administrator.
SMB Password: **** is the domain administrator password.

The problem is on the screenshot.

There is a video, but there is no Host field. I can’t understand what should be entered there. There are videos with other versions and there is no such strange field there:

Hi pal… english speaking forum and (personally) i don’t understand cyrillic characters. My guess is that’s russian but… only because it’s the biggest country using cyrillic (also your username helps)…

Would you kindly edit the post for helping us better understand? :slight_smile:


I forgot to insert the translated text(.

Screenshot is in russian dude… :slight_smile:

In general it is not clear what smb Host is?


SMB Host is the IP or FQDN of your samba / Windows Host. No slashes, backslashes or any funky stuff, just identify which host you want to use.

The actual share name (Just the Share like a NetBIOS name, max 15 chrs). Also here NO slashes, backslashes or any funky stuff.

This should work.

My 2 cents

1 Like

I’m totally stumped now(. I don’t know what’s wrong

Why use SMB/CIFs instead of the native UN*X / linux protocol NFS? NFS has much less overhead, using NFSv3 does not need any Authentification (Except for IPs, which are anyway static)…

I always use NFS. On the backup target, NFS retains the correct permissions, SMB/CIFs implements Windows like ACLs, which do NOT reflect what UN*X / Linux uses or needs.

As I see it, you’re trying to use a Windows Group, not a user for Authentification. I don’t think this can work.

In the screenshot, a NethServer uses Duplicity / NFS to backup to a Synology NAS. This works rock solid!

My 2 cents

Thank you for the answers. I thought having a computer in the domain and a network folder was enough for backup. However, you need to bring up an NFS server!

Why should one use a “domain member container” to backup the AD? If the AD is screwed, you simply have no backups accessible?

One can ALWAYS use a SMB share instead of NFS: Here a USER and PASSWORD are needed, not a GROUP!!! On a Windows PC, you also have to log in using a USER, not a GROUP. A GrOUP is not intended for Login!
So simple!

Maybe you need to read up about simple Windows handling BEFORE blaming Linux?

My 2 cents

1 Like