NextCloud WebDAV connection problem

NethServer Version: 7.3

I have problems connecting to NextCloud with WebDAV in windows.
I am using WebDrive, and can connect to other servers (non NC/NS) without problems.
If I connect as suggested like this;

I connnect without problems, but then when I copy a file using windows explorer, no matter the size 1k, or 400mb, I can copy the file no problem, then next file copy, fails, saying not enough space available, 0 bytes available. A disconnect, and reconnect lets me copy one more file again.

I have read in many places, and the webdav connection we should be making is;

If I try to connect this way, same problem.

I just seen in NC manual that WebDrive is not listed as supported. I have licenses for WebDrive, so I want to figure out what is wrong. I tried the trial for NetDrive and it works, no 0 bytes available error, and can copy many files, at least so far. But, NetDrive is painfully slow, and I there are basically no settings that I can find, so I can’t even look to see what is different between NetDrive/WebDrive.
Right now, I guess I’m just hoping someone has had this problem before with WebDrive.

Abou this you can try to set user quotas (from Nextcloud’s users admin page) to see it the error goes away.

@dnutan Thanks for the idea, I tried it, and no difference, BUT, while trying that, I changed the connect directory to the root of the user, and it worked. I was connecting directly into a folder and that is what was giving me the problem. Now, I need to connect directly into a folder, but at least I have a workaround that seems to work for now.
Should I not be able to connect WebDav folder instead of the root?

Forgot to mention to reconnect the webdav mount after changing quotas …anyway, it didn’t make the trick.

Yes, you should be able to connect to a folder.

I did reconnect the webdav mount after changing the quotas, but I have managed to get it to work now.
This only seems to affect WebDrive, as I can connect with NetDrive, and it works, but it is deadly slow, unusable for me, 30s to negitiate a file transfer of 1kb. Larger files are ok. Not a big deal as I don’t have a license for NetDrive anyway.
In case this helps anyone else;
The issue is quota, but also what level of folder you are connecting into with WebDrive.
If I connect to the root WebDAV share for user, all works ok.
If I connect into a SubFolder, the connecting users folder, or a shared folder, and the user’s quota is set to unlimited (user connecting, or owner of share) then I can send one file, not matter the size, and can’t send another file. If I change the users quota, or in my case I am connecting into a shared folder, so I just changed the quota of owner of share from unlimited to 1 TB, and all seems to work fine…so far.