Nextcloud Support related questions - php config changes as well as minor update

NethServer Version: NethServer release 7.3.1611 (Final)
Module: Nextcloud 11.0.2
Hello Team,

I’m digging more into setting up Nextcloud for our office. I’m looking to update the Upload size limit for adding files to Nextcloud. I know I can do this in the php.ini file. So based on what I’ve learned from the forums the location of Nextcloud files is in /usr/share/nextcloud/. I added a small phpinfo.php file there to give me information on my php install. I’m confused where I can make my php.ini file changes?

  1. Which php.ini does Nextcloud use…the one in /etc/php.d/nethserver.ini or is there another location?
  2. I noticed in my phpinfo.php file the version of php installed in sandbox for Nextcloud 11 to work on Nethserver is 5.6.25. The Nextcloud Admin manual says Nextcloud 11 needs php version 5.6.6. What is the reason for the Nethserver version of php to be lower? Here is a link to the Admin page I referenced:
  3. I’m seeing my Nextcloud 11 logs get filled up with the following error: utomatically populating $HTTP_RAW_POST_DATA is deprecated and will be removed in a future version. To avoid this warning set ‘always_populate_raw_post_data’ to ‘-1’ in php.ini and use the php://input stream instead. at Unknown#0. Searching Nextcloud forums I find that I can easily fix this by setting the variable “always_populate_raw_post_data = -1” in my php.ini file. Which php.ini file do I make this change in when using Nextcloud in Nethserver? And what will enabling this setting do for any other apps I use in Nethserver?
  4. I’m seeing a minor update message in my Nextcloud 11 to version 11.0.3 is available. What is the procedure when using Nextcloud from Nethserver? Do I update Nextcloud myself from within Nextcloud…or do I need to wait for Nethserver to release this minor update to Nextcloud in the Software Center?

Thank you.

The php.ini file for php 5.6 is located at /etc/opt/rh/rh-php56/php.ini
In Nextcloud 11 we also use a .user.ini file: /usr/share/nextcloud/.user.ini

Max upload size can also be tweaked from Nextcloud itself (Admin -> Additional Settings).

always_populate_raw_post_data=-1 it is set already in the .user.ini file.

The recommended way to update is to wait for the release of a new package.


Thanks @dnutan!

Don’t know how I missed the ability to change the upload filesize right from Nextcloud itself.

I also found the always_populate_raw_post_data=-1 was commented in the /etc/opt/rh/rh-php56/php.ini file. I’ve removed the comment and so far the errors have stopped. Thanks for confirming where these files were for me.

I’m very happy to be on Nextcloud 11 so no rush for minor updates yet. I’ll wait for the next update from the software center.

Appreciate the help!