NextCloud - request entity too large

I did a search on the forum for a fix first, but did not find one.

This seems to be a semi-common issue on the web, but after trying the primary fixes listed on the net I still can’t get around it.

I have made the following changes:

  1. Php.ini - post_max_size = 50G
  2. php.ini - upload_max_filesize = 50G
  3. Nextcloud Gui > Admin > Additional Settings > File Handling > 50 GB

Still having the issue when uploading files over a few MB in size. I think there might be an apache setting to change, but I am not seeing the Apache config on the file system. Can someone point me in that direction if they can’t offer a fix.

Thank you.

have you seen this link?

perhaps something about your htaccess?

Restart httpd ?

I did restart Apache, but thanks for the check. :grin:

I did not see that, Going to check it out now. This might be exactly what I have been looking for.

Updated the settings suggested in the post and restarted apache, but I am still hitting the limit.

Could something in /var/www/html/nextcloud/.htaccess and/or /var/www/html/nextcloud/.user.ini be interfering with your settings?

Maybe? What settings would you recommend I Change/Check?

Commenting out from those files the changes you already applied to php.ini, and restarting httpd

I will check those files, but I am a doubtful that the USER.ini and .HTaccess files have the same syntax and command structure as the PHP.ini file. Without a 1-to-1 identification I will be a bit lost in identifying the options to comment out.

I think you can forget about those files because their settings are set through Nextcloud admin page, which you did already (maximum upload size). Excerpt of the .htaccess file:

<IfModule mod_php5.c>
  php_value upload_max_filesize 513M
  php_value post_max_size 513M
# ...

Sorry for the inconvenience.

On Nextcloud documentation they mention a couple of apache directives (SSLRenegBufferSize, LimitRequestBody) that could be related to this error.

As a last resort, there is an experimental NextCloud app (FlowUpload) that could serve as a workaround.