Nextcloud onlyoffice - unable to get it to function

Hi, I had a non functioning version of onlyoffice in a nethserver nextcloud install. Tried to reinstall according to the Wiki.

First I tried installing the latest version of onlyoffice document server (7.4.1) according to the centos repo.
This version failes because:

  1. line 21 (ssl on) directive is obsolete and now blocks starting nginx
  2. the includes directory has the file ds-docservice.conf that failes the nginx config check in the signal-event nethserver-onlyoffice-update command.

The ds-docservice.conf file contains two redirect statements that generate this error: [emerg] NNNNN#NNNNN: unknown “the_prefix” variable. I think the 7.4.1 nginx won’t work at the moment.

So I tried to re-install the latest known running version of onlyoffice (7.3.3-49.el7).
The ds* services run fine, the nginx is again stuck: [emerg] NNNNN#NNNNN: unknown “secure_link_secret” variable. Output of stystemctl status ng*:

Aug 16 20:20:51 server.fqdn nginx[10531]: nginx: [warn] the "ssl" directive is deprecated, use the "listen ... ssl" directive instead in /etc/nginx/conf.d/ds.conf:21
Aug 16 20:20:51 server.fqdn nginx[10531]: nginx: [emerg] unknown "secure_link_secret" variable
Aug 16 20:20:51 server.fqdn nginx[10531]: nginx: configuration file /etc/nginx/nginx.conf test failed

The secure_link_secret directive is in line 44 of /etc/nginx/includes/ds-docservice.conf
I also had a look on the signal-event onlyoffice-update script, the secret key is on disk (/var/lib/nethserver/secrets/), the database and the nextcloud config but no clue where this error comes from.

I seem to be out of options, any help/leads will be appriciated.

Sorry for the late answer.
Please test the following module, it should fix the issues:

yum -y install