Nextcloud Mac client hangs, won't sync

NethServer Version: 7.9
Module: Nextcloud

I think this is more a Nextcloud issue than a Nethserver issue, so I’ve posted there as well, but would appreciate any guidance anyone can give. In short, the Nextcloud Desktop client v3.3.6 (the latest available for download) isn’t syncing, or really doing much of anything, on my Mac running Catalina (10.15.7). The menu bar icon doesn’t appear, the folder isn’t synced, and no indication appears on or in the folder that it’s anything different from any other folder on the computer. I can quit and restart the Nextcloud client process, with no effect. Not sure if, or where, it logs errors, or what else to check.

Can you throw away your previous configuration from your current MacOS user?

Looks like that’s accomplished by deleting (or renaming) ~/Library/Preferences/Nextcloud, and I also did ~/Library/Caches/Nextcloud for good measure (it seemed similar to a fix noted in this issue). But when I do that and then re-launch the client, I’m seeing the same behavior.

I’m also seeing that, when I run the CLI tool, I’m getting a segfault:

 ✘ dan@tardis  /Applications/  ./nextcloudcmd ~/Nextcloud
12-17 08:01:28:421 [ warning ]:	Error receiving trust for a CA certificate
12-17 08:01:28:424 [ warning ]:	Error receiving trust for a CA certificate
12-17 08:01:28:425 [ warning ]:	Error receiving trust for a CA certificate
Please enter user name: ***
Password for user ***: [1]    30210 segmentation fault  ./nextcloudcmd ~/Nextcloud

Also CA seems not… that compliant.
The installation has a self-signed certificate?

No, notwithstanding the error, it’s serving a current, valid Let’s Encrypt cert:

 Testing server defaults (Server Hello)

 TLS extensions (standard)    "server name/#0" "renegotiation info/#65281" "session ticket/#35" "heartbeat/#15"
 Session Ticket RFC 5077 hint 7200 seconds, session tickets keys seems to be rotated < daily
 SSL Session ID support       yes
 Session Resumption           Tickets: yes, ID: yes
 TLS clock skew               Random values, no fingerprinting possible
 Client Authentication        none
 Signature Algorithm          SHA256 with RSA
 Server key size              RSA 2048 bits (exponent is 65537)
 Server key usage             Digital Signature, Key Encipherment
 Server extended key usage    TLS Web Server Authentication, TLS Web Client Authentication
 Serial                       0454AABE9670C39595D9234BD26925C7D2B8 (OK: length 18)
 Fingerprints                 SHA1 97E0BB19397849CB28F6A4004BD29BC1E1A72CBE
                              SHA256 50CC19940A5673E750618FB2F74C2CF3867C4CC1BBDC1EAC464F012EDAFF5CC0
 Common Name (CN)   
 subjectAltName (SAN)
 Trust (hostname)             Ok via SAN (same w/o SNI)
 Chain of trust               Ok
 EV cert (experimental)       no
 Certificate Validity (UTC)   62 >= 30 days (2021-11-20 13:05 --> 2022-02-18 13:05)
 ETS/"eTLS", visibility info  not present
 Certificate Revocation List  --
 OCSP URI           
 OCSP stapling                not offered
 OCSP must staple extension   --
 DNS CAA RR (experimental)    available - please check for match with "Issuer" below
 Certificate Transparency     yes (certificate extension)
 Certificates provided        3
 Issuer                       R3 (Let's Encrypt from US)
 Intermediate cert validity   #1: ok > 40 days (2025-09-15 16:00). R3 <-- ISRG Root X1
                              #2: ok > 40 days (2024-09-30 18:14). ISRG Root X1 <-- DST Root CA X3
 Intermediate Bad OCSP (exp.) Ok

Next idea: permission on filesystem that are not ones the expected by NextCloud client.
Change Nextcloud client version.
3.3.5 or 3.4.0 RC2


One thing irritating me here:

On Macs, generally all binaries are either in /applications or for a chosen few: /system/applications.
Applications appears nationalized, depending on language used…

Library is - where settings are kept. There’s a global one under /library, but also one for each user, under the users account /library ( /users/USERNAME/library ).

Maybe the App landed in the wrong place (in library), but I strongly assume that’s where the NC App places it’s global settings.
The synched folder is usually under your User, eg. /users/Dan/Nextcloud-Sync.

So in all the above, I’m missing the actual App !!!

My 2 cents

Just installed the App:

My Macbook runs in German, hence the localized names of “Programme” instead of Applications…
NextCloud is Nextcloud, and here’s the App itself…

1 Like

I have a MacBook pro running high Sierra and get the same error randomly but I am also getting an issue with Mac not letting me add internet accounts for some reason and caldav and carddav are keep asking for password then says can’t find account not sure if the two are related

Hi @Shane_Treweek

That sounds more like a corrupt profile to me…
Try creating a new user (Testuser), and creating internet accounts there, it should work.

If it does:

→ You’ll need to create yourself a new profile!

My 2 cents

1 Like

thanks Ive realised my issue is not the same sorry @danb35 for unintentionally hijacking this support request

but is one of the files to be synced mabey have an illegal character in it
also on the mac in question if you go to settings in the nextcloud desktop app theres a setting to create debug archive you can access logs in there