Nextcloud installation (cannot add phone number, and opcache doubts)

NethServer Version: 7.9.2009

Nexcloud: 24.06

I have a couple of small issues coming up with a Nextcloud install as outlined below.

  1. I have been following other tutorials in doing this, as this feature is not working as i cannot add a phone number on the web interface. On the other tutorials, it always says to stop nextcloud when editing config.php, but i am not sure how to do so on Nethserver. I did use occ maintenance:mode --on and then off but i am not sure if that is effective when changing the config.php as i have errors below. Moreover, all the links etc for scripts are much different on a vm or baremetal install so being a newbie i am kind of lost.
  2. Now i have errors as outlined below and mentioned above. I dont see any references to opcache in the config.php setup so not sure what to do other than reboot.
    I dont believe that rebooting all the time is the best solution, can someone please provide some guidance as the nethserver install for nextcloud is alot different than on their documentation.

I am having issues with the following topic presented howto:nextcloud [NethServer Wiki].

Your installation has no default phone region set

*** Your installation has no default phone region set. This is required to validate phone numbers in the profile settings without a country code. To allow numbers without a country code, please add “default_phone_region” with the respective ISO 3166-1 code :arrow_upper_right: of the region to your config file.***

This advice is not important. If you want to, you can follow as advised, editing /usr/share/nextcloud/config/config.php file to add your country’s “default_phone_region”. Here’s an example for Italy:

*** ‘default_phone_region’ => ‘IT’,***

ERRORS******************

There are some warnings regarding your setup.

  • The PHP OPcache module is not properly configured. See the documentation :arrow_upper_right: for more information.
    • The OPcache interned strings buffer is nearly full. To assure that repeating strings can be effectively cached, it is recommended to apply opcache.interned_strings_buffer to your PHP configuration with a value higher than 8 .

Please double check the installation guides :arrow_upper_right:, and check for any errors or warnings in the log.

Check the security of your Nextcloud over our security scan :arrow_upper_right:.

Hi @koolandrew

You seem to enjoy doing things the very complicated way.
I have setup 30 NethServers for clients, all as VMs running in Proxmox, all as AD and with NextCloud, Zabbix (Monitoring) and other services.

The only thing I’ve had to do was click on the link in Software Center, and that’s it!
I had a working Nextcloud!
OK, full AD integration with SSL took a bit more, but nowhere like what you’re doing!

Why not give the intended method a try? It works!

My 2 cents
Andy

Hey Andy, i am not sure what you are referring to. I am not using AD integration, where did that come from. I do have a working nextcloud as i did connect to the software centre, that is exactly what i did But since you are guessing, i would guess that you havent set up the admin console as you dont have a fully working Nextcloud unless the setup is continued on the web interface and/or config.php. If a customer or user needs to enter a phone number in their profile, the config.php needs to be changed, and again, this is according to nextcloud as well as the wiki provided by nethserver.

I have used the intended method, have not deferred from it, and now there are some issues.

Hi

I am using AD integration, but that’s just an added difficulty…
My point is I do have 30 fully working Nextclouds, and without playing around with config.php…
Not that I’m averse to config.php, as an old Linux hand, I have no issues using console…
But I don’t waste time if it’s not needed…

The Doks also state:
"This advice is not important…"

If any users, they must use international dialimg codes first, that’s all…
This has NO relevance on functioning of Nextcloud as such!

All my Nextcloud installs allow a phone number to be added via user-web GUI…

How much RAM does your server have? (This question only has to do with OCcache…)

And:

I have NEVER had to use the admin console (except the occasional OCC comand to remove an app blocking the update. There is NO such recommendation or statement about finishing the Setup on the Web Interface OR using the admin interface…

I did check here:
https://wiki.nethserver.org/doku.php?id=howto:nextcloud

I think you got this information from NextCloud, not from NethServer Doks…

There are several instructions for NextCloud, the ones on NethServer are specific to NethServer, those on Nextcloud are rather generic.

Stick to the docs on NethServer relevant to Nextcloud, it’ll work!
(And there’s absolutely no reference to OPcache on NethServers Doks - so why bother?)

My 2 cents
Andy

I am happy for you, that you have so many successful installations, but it doesn’t help one bit in trying to solve this issue or correct an error that I got on the admin panel of nextcloud. I have installed nethserver on a proxmox vm as well with tons of cpu and ram available but again no bearing on why I cannot add a phone number. I tried before changing the config.php and I could only enter a get digits with or without the + sign. Now after changing it, and rebooting the server to get rid of the errors , when entering the phone number, I get prompted to re-enter my password and then after 2-3 digits with or without +, I see a checkmark and no phone number displayed.

I didn’t ask for this issue, I am only attempting to find a solution.

occ config:system:set default_phone_region --value="${COUNTRY_CODE}"

1 Like

Thanks for the command using occ. I just tried but unfortunately got the same results.
I am guessing that it must be a permission thing elsewhere that i am not aware of.

What is the exact output message from the occ command?
Did you try specifying the country code like this (replacing IT from Italy with the desired country code)?

occ config:system:set default_phone_region --value="IT"
1 Like

I tried your command and i got back,
System config value default_phone_region set to string IT

I looked at config.php and it is there.

I cannot save a phone number, i have a video but i cannot attach it on this forum.

i did some more searches on this issue, and supposedly someone mentioned on reddit they had the same issue (w/o nethserver) and they upgraded to 25.0 and it fixed it.

I have read on the wiki that i am supposed to use the software updater, and the latest version of nextcloud is not available as of yet.

I have an update. When i use IT, i can enter an Italian number but not one starting with +1 or 416 or anything like that.

It appears that there is some script that automatically adds + then country code after you enter the number, so there is no way of adding any other country number which makes it pretty useless for this. I guess this is purely a nextcloud issue, sorry for the bother.

Same issue with any other numbers.

Hi @koolandrew

An old saying in english goes: Too many cooks spoil the broth…

Choose one, and stick to that, don’t mix issues, symptoms, solutions from several places, like NethServer or Nextcloud Forums, or even Reddit…

At the moment, it’s not yet ready - nor needed. NextCloud needs no fumbling with OPcache, and user entering of Telefon Numbers “just work”, so far in more than 40 installations of NextCloud.

Then again, I don’t ask several sources for solutions, I stick to one!!!

Personally, I’d say your issues come from mixing Nextcloud w/o NethServer, and NethServer’s Nextcloud…

My 2 cents
Andy

Andy, lets review the facts.

You love to recant about your 40 installs of Nextcloud, congrats! The fact that you havent experienced this issue doesnt mean it hasnt happened. The repetition of your nextcloud installation experience, doesnt make this issue go away.

1 The OCP error message came from the nextcloud install through nethserver, and it was because these changes were made by editing the config.php…end of story. I didnt ask for it, i wasnt looking for extra work.
2. The info i found on reddit, was based upon someone else who is having exactly the same issues. In fact, i found others who had the most recent issues that i had, on older versions. There is even a script in github that is supposed to fix it, and since been incorporated in nextcloud.

And your last statement, is that i am “mixing Nextcloud w/o NethServer, and NethServer’s Nextcloud…”…what does that mean. I am only following the install from nethserver directions, and like the you the grand poohbah of nextcloud installations on nethserver, had no issues installing it. Zero, none.

The issues came once i tried to enter a measly phone number, which is not available if i set the region to CA or US. It works for IT, but only IT.

This issue has nothing to do with my installation or anything that you have added at this point.

Hi @koolandrew

AND: No link to these “other” tutorials…


No matter what Hypervisor one uses (VMWare ESXi, XEN, Hyper-V or Proxmox), this statement is just untrue:

The only differences between a VM and “native install” are the drivers used, eg networking, storage, etc…
There NEVER is a difference for any paths to scripts!

And: Until your last post, this is the ONLY reference / hint you make, that you are using a VM!.
VMs are they way to go nowadays, it makes for higher availability, less issues with hardware or migrations and several Pluspoints like the option to do a snapshot before any major updates…


Your issue comes with as much relevant infos like the typical office user, who despite being english speaking, does not understand the difference between:

The Internet is not working (Inplying Google, FB, others are down!)
and
My internet connection is not working…

I have NO issues with newbies, I’m known to be quite helpful to most.
But give as much correct infos as possible, including, if possible, where did a specific info come from.

This is one good statement from you:

“I am having issues with the following topic presented howto:nextcloud [NethServer Wiki] .”

Note that the document does state that it’s only needed, if you intend to allow non-international phone number notation. And, it also states that: " This advice is not important."…

I do mandate that my users must use international notation, without spaces…
Coming from small Switzerland, our numbers and notation differs a lot from eg Germany or France, both much larger, with longer numbers (and different spacing conventions!).

(German) Screenshot showing phone number in Nethservers Nextcloud User-Settings:


Nextcloud is a great project, and has improved a lot it terms of functionality and stability since forking from Owncloud. It still suffers from Announcement-Bloat, and a couple of “bad implementations” like the rather unstable “Full text index search” using Elasticsearch…

’nuff said!

Let’s leave things like that, others here may help…

As always with a new installation (Even for pros…): Good Luck!

My 2 cents
Andy

2 Likes

You could edit /etc/opt/remi/php80/php-fpm.d/000-nextcloud.conf and set php_value[opcache.interned_strings_buffer] = 16 to get rid of this message.

1 Like

A post was merged into an existing topic: Adding Domain Names

I can’t reproduce.

I tried US phone numbers (10 digits, starting with 2,3 and so on). When US is selected as phone region the “+1” is correctly prepended.
If I include the country code, my AT numbers are working too.

Maybe you’re hitting an annoying known bug clearing the field when you’re not fast enough typing the number, see also [Bug]: AccountManager clears input field during typing (User profile) · Issue #33440 · nextcloud/server · GitHub

1 Like

Hi Markuz,

That was a good post in github. I was able to fix it by entering my phone number on a notepad, and then copying it to the field and it saved it.

It simply appears that the field times out for some reason, like in one second after the first digit is entered. It is also interesting that it is only mentioned on CentOS installs.

I am not sure if this would have to be a different topic, but i was thinking of using Nethserver 8, as it uses the new format and any os that you choose, but maybe i am still way too soon.

What do you think?

1 Like

It’s only one thread about that issue so we don’t really know if maybe other distros are affected too.

NethServer 8 will be great and solve a lot of issues but it’s not production ready yet.
Currently there are recommended OS, it doesn’t work on all distros, see also Quickstart | NethServer 8