Nextcloud in NS8 fails with “503 Service not available”

Trying to open Nextcloud in NS8 gives me “503 Service not available”. The Nextcloud modules are all active.
What can I do?

Which URL are you using ?

What is the output of:
hostname -f
hostname -d


hostname -f is ‘’
hostname -d is ‘’

Btw, I have the same error with roundcube.

Nobody knows how Nextcloud can be accessed externally in NS 8 ?

Is it a new installation? Try to reinstall Nextcloud.

If it has already some user data, try to clone the Nextcloud instance.

It’s a new installation on rocky linux. I removed Nextcloud1 and installed a new instance Nextcloud2, but with the same result. “No service available”.
I saw that the app is listening at a strange port on
Do I have to create a virtualhost in order to connect to the app from outside?

does it work from LAN?

No, Traefik (the NS8 front-end reverse proxy) is configured automatically for that purpose. I bet 503 is generated by the Nginx component of NC

Please try to run podman ps on your side, you’d get a similar output: paste it here.

[root@ns8 ~]# ssh nextcloud1@localhost
Last login: Wed Jun 28 16:33:19 2023 from ::1
[nextcloud1@ns8 ~]$ podman ps
CONTAINER ID  IMAGE                                    COMMAND               CREATED      STATUS          PORTS                    NAMES
62f39001f39b  localhost/podman-pause:4.1.1-1660063436                        5 weeks ago  Up 5 weeks ago>80/tcp  54285f1d5dd9-infra
9ca3f75351f9    --appendonly yes      5 weeks ago  Up 5 weeks ago>80/tcp  nextcloud-redis
349b318c283f        mariadbd              5 weeks ago  Up 5 weeks ago>80/tcp  nextcloud-db
985b13eb0420   /usr/bin/supervis...  5 weeks ago  Up 5 weeks ago>80/tcp  nextcloud-app
2cf311d6f981    nginx -g daemon o...  5 weeks ago  Up 5 weeks ago>80/tcp  nextcloud-nginx

I’d ask to look at the Logs page, but we still didn’t release the new version that should improve it a bit!

Interesting! ‘podman ps’ gives me this:

7b7ab1018768    redis-server /dat...  26 hours ago  Up 26 hours              redis
9c58f7650585  -config.file=/etc...  26 hours ago  Up 26 hours              promtail1

There are no containers started for nextcloud, mariadb or nginx. Whereas Grafana is not even installed.

You missed the first command:

In your case:

ssh nextcloud2@localhost

Well and then?
The result of ‘podman ps’ is unchanged. No Nextcloud container.

No containers at all? Did you run the configuration?

Check out the procedure described here Nextcloud — NS8 documentation

After logging in as nextcloud2@localhost, ‘podman ps’ gives me this:

0dcfb47c7391  localhost/podman-pause:4.4.1-1683632637                        4 hours ago  Up 4 hours>80/tcp  8d901f2e73f7-infra
3e141d276cd5    --appendonly yes      4 hours ago  Up 4 hours>80/tcp  nextcloud-redis
b9f548154e32        mariadbd              4 hours ago  Up 4 hours>80/tcp  nextcloud-db
98ea98a07278   /usr/bin/supervis...  4 hours ago  Up 4 hours>80/tcp  nextcloud-app
0f4e42fcd224    nginx -g daemon o...  4 hours ago  Up 4 hours>80/tcp  nextcloud-nginx

But I don’t get the nextcloud gui. Service unavailable.



I installed a fresh NS8 system based on debian.
Roundcube works now, mainly because HTTP to HTTPS is disabled.
The ACME certificate is provided by the pfSense firewall.
How can HTTP to HTTPS be disabled for Nextcloud in Traefik?