Nextcloud Cron Issue

Greetings, after a recent upgrade of Nextcloud, I am now receiving this email message once every 5 minutes when the cron for Nextcloud runs.

PHP Fatal error: Allowed memory size of 4294967296 bytes exhausted (tried to allocate 20480 bytes) in /usr/share/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php on line 133

I have rebooted the server just in case there was any kind of cached issue, that seems not to have fixed anything. I’ve also attempted to adjust the actual memory limit, both in the cron or the configuration, no dice.

But I’m literally getting emails every 5 minutes and it’s driving me insane! Anyone else having this problem or is it just me?

Maybe we need to add the apc.enable_cli parameter to the cron job.

*/5 * * * *   apache /usr/bin/scl enable rh-php73 -- php -d memory_limit=512M -d apc.enable_cli=1 -f /usr/share/nextcloud/cron.php

Or from the Nexcloud manual:


APCu is disabled by default on CLI which could cause issues with nextcloud’s cron jobs. Please make sure you set the apc.enable_cli to 1 on your php.ini config file or append --define apc.enable_cli=1 to the cron job call.

1 Like

8 posts were split to a new topic: Backup fails to dump rh-mariadb105 database

PR created:


Thank you for the PR!
Do you think the fix is worth creating a new issue?
Or we can just merge it and release on with the nextcloud verion?

If it’s breaking the cron job for this user, it probably is (or will) for others, so I don’t think I’d want to wait for the next NC release–but before we’d release, might want to also see what’s going on with the database issue mentioned up-topic, in case it also needs a fix in the package.

The Cronjob issue is solved (that APC modification to the cronjob solved it). The big issue now is this mystery service that is now stopping backups. What do I do about that?

A post was merged into an existing topic: Backup fails to dump rh-mariadb105 database

A post was merged into an existing topic: Backup fails to dump rh-mariadb105 database

We have some installation of NC21 around and none of those is raising the error :thinking:

I would like to wait few more days before the merge to see if the error is more widespread.