Nextcloud 18 - update creates APCu issues

Since Nextcloud 18.0 and 18.01 I see the following in the logfile

Info cli Memcache \OC\Memcache\APCu not available for distributed cache
Info cli Memcache \OC\Memcache\APCu not available for local cache

I think this comes from a missing apcu.enable_cli=1 in php.ini. But where to add so that this will not be overwritten with each update?

I’m on NS 7.7 and php 7.2

The option is disabled by default in this non-template file: /etc/opt/rh/rh-php72/php.d/40-apcu.ini
APCu is disabled by default on CLI which could cause issues with nextcloud’s cron jobs. Please make sure you set the apc.enable_cli to 1 on your php.ini config file.

Old message but maybe relevant:

1 Like

Thank you - I go with the loglevel => 1, solution and leave it with apcu.enable_cli=0

Could you mark this topic as solved please, or do you have anymore questions.