NextCloud 15.0.7 update - mysql needs updating as well - Advice please

nextcloud

(Charles) #1

Nextcloud 15.0.7
NethServer release 7.6.1810 (final)

Hello Support,

I’ve upgraded my Nethserver today and with it came an upgrade to Nextcloud 15.0.7. In the Nextcloud update I’m now seeing the following warning:

MySQL is used as database but does not support 4-byte characters. To be able to handle 4-byte characters (like emojis) without issues in filenames or comments for example it is recommended to enable the 4-byte support in MySQL

The warning has a link to a Nextcloud page - https://docs.nextcloud.com/server/15/admin_manual/configuration_database/mysql_4byte_support.html

Since Nextcloud is running on Nethserver I’m hesitant to make any changes without requesting a solution from the Nethserver support team. Could you assist in advising me what needs to be done in my database and the commands I’ll need to run to remove this warning?

Thank you in advance for assistance you can provide me.


(Markus Neuberger) #2

It’s for Nextcloud 14 but the steps are the same:


(Charles) #3

Thank you @mrmarkuz for your reply and link to a possible solution.

One comment that intrigues me is about waiting for an update from Nethserver to correct this warning? Is that something Nethserver can confirm will occur in the near future? If this warning is not critical and doesn’t impact my Nextcloud running on Nethserver I’d rather not make any changes to my database if Nethserver will clear this warning for us in a future release.

Perhaps the Nethserver support team can comment.

Thank you.


(Markus Neuberger) #4

Found two issues:

The mariadb settings may affect other Nethserver applications so it will not be integrated.

The warning is not critical.


(Giacomo Sanchietti) #5

Excellent catch @mrmarkuz!

@greavette if nextcloud is the only thing installed using MariaDB, you can follow the commands linked in the issue for NC 16.


(Michael Träumner) #6

It’s always a good idea to ask at the forum. Also I would install a test-server at a virtual environment, do a snapshot of the test server and install the update here first. Cause of this is, that not everybody has the same system and so it could happen that it works for everybody but not for you. If so, you can post your errors and we try to find a workaround for your problem, before you have it on a production server.


(Charles) #7

Thank you all (@giacomo, @m.traeumner and @mrmarkuz) for you taking the time to answer my post.

I see that Nextcloud 16 is out now so I’ll wait to upgrade to Nextcloud 16 before I think about making any database changes. And the suggestion to do this on a test server first is always a good idea! :slight_smile:

As for making sure that nextcloud is the only thing installed using MariaDB…how do I know? I have the following apps installed on my Nethserver:

  • Email
  • Instant Messaging
  • Nextcloud
  • Webtop
  • Roundcube
  • MariaDB

Is Nextcloud the only app that uses the MariaDB based on the apps I have installed?

If the warning is not critical I’m tempted to ignore it. But I don’t like seeing warning messages on my Nextcloud…maybe my OCD but it makes it look messy for me. :slight_smile: What does this warning mean? Is there a time when my MariaDB/Nextcloud should be able to handle 4-byte characters?

Thank you.


(Markus Neuberger) #8

Instant messaging and roundcube use mariadb too.
The warning is about wrong database encoding so you can’t use emojis in Nextcloud apps.


(Saito Benkei) #9

that can only be a good thing :smiley: (ups…)


(Charles) #10

When would we use emojis in Nextcloud Apps? I have the Nextcloud Java Chat app installed so perhaps emojis won’t work in there (not that it matters). I also use Onlyoffice to display documents and edit them in Nextcloud. Is that another example of not being able to use emojis (again…not that I need to use emojis in my documents either).


(Marc) #11

Reading Nextcloud docs, it seems the change could also affect database backups:

If you use mysqldump make sure to add the --default-character-set=utf8mb4 option. Otherwise your backups are broken and restoring them will result in ? instead of the emojis, making files inaccessible.


Nextcloud complaining about MySQL being non UTF-8
(Markus Neuberger) #12

I tested it with utf8mb4 database. It’s really possible to use emojis in filenames (crazy) and comments.

I recommend to not change the character set and ignore the warning.

The file content is not affected.


(Markus Neuberger) #13

@dnutan, you’re right, thanks for pointing that out.
Without the option you get faulty db backups if utf8mb4 is used.