Nextcloud 13 - Call for QA!

I thought Nextcloud 13 is already tested so is in nethserver-updates. If is not it’s a bad practice to put it there, i think. How we can avoid this is the future?
Nethserver is a great piece of software but i had few problems after update that i thing shouldn’t happen on a server. Is it possible or maybe needed by users to make updates more restricted (more safe)? Cheers and thanks for Your support.

definitely yes. nethserver-updates is enabled by default, so with an install of NC through softwarecenter you get a broken NC13 by default!
Not easy to solve for a newcomer. Not good for reputation of NS.

2 Likes

@dev_team Could you have a look for it.

Holy s***t! I bet it’s my fault, but I don’t have access right now to fix the problem.

@flatspin, you can fix your installation by installing everything with testing repository enabled.

Sorry, I will fix ASAP :frowning:

2 Likes

Don’t wory. No problem for me so far. I installed from cmd with updates-repo disabled and got NC 12. Update with testing-repo worked perfect. So I have a working installation NC 13. Also found a solution for cert issue with onlyoffice in NC 13.
Everything is fine for me. :wink:

2 Likes

Of course the nextcloud package should have been published in nethserver-testing.
I used the wrong command this morning, the problem should now be fixed.

Mirrors will be in sync in few hours.

3 Likes

3 posts were split to a new topic: Nextcloud cryptic usernames

And when will NC13 pass from testing to updates repo?

Thanks in advance

When it’s ready I guess and it’s tested enough.
Would you mind helping us? So we can shorten this period

1 Like

Upgraded our production server, no problems so far.

4 Likes

NexCloud talk app looks amazing! Very easy and with good performance. They did an amazing job
The WebUI looks very nice and fast

remember to enable the app

and to enable this option

to see the user list

image

Hi Team,

Here are my results of upgrading Nextcloud on our test server.

Our server specs are:
NethServer release 7.4.1708 (Final)
Kernel Release - 3.10.0-693.17.1.el7.x86_64

I have this Nethserver Test Server spun up since I installed my prod server. Both my Test and Prod run a domain and have Nextcloud installed. I’ve been keeping them both in step with updates whereby I’ll update my test serer first and confirm it’s working and then update my Prod server.

My Prod and Test Nethserver are both running Nextcloud 12.05 (latest version from Nethserver).

I’ve issued the following command on my test server:
yum install nethserver-nextcloud --enablerepo=nethserver-testing

Install was successful. I’ve now tried to login to my test server but my login is not working when I use an ID I’ve created in Nethserver. I can see the login screen and I’ve confirmed I’m using the correct login ID and the correct password. I receive an error that says:

Internal Server Error
The server was unable to complete your request.

If this happens again, please send the technical details below to the server administrator.

More details can be found in the server log.

Technical details

Remote Address: 10.232.x.x
Request ID: WqFq72Z2m529x8XCEE5rMgAAAA4

I’ve then logged in with the default admin (Nextcloud) account. I can login with this account but everything is extremely slow (both Chrome and Firefox). In the Settings page (used to be called Admin) I can see in my ldap a ‘Configuration Incorrect’ message.

I’ve looked at the logs and I can see the following:

Error core Error while running background job (OC\ServerNotAvailableException): Lost connection to LDAP server.
Fatal webdav Sabre\DAV\Exception\ServiceUnavailable: OC\ServerNotAvailableException: Lost connection to LDAP server.
Error no app in context OC\ServerNotAvailableException: Lost connection to LDAP server.

Anyone else having issues with upgrading to Nextcloud 13 when on a domain?

Thanks,

Updated/Installed from:

  • OpenLDAP + Nextcloud 12.04
  • OpenLDAP + Nextcloud 12.05
  • Local AD + Nextcloud 12.05
  • Clean Install on Local AD

Passed the 4 test cases.
Hit some Nextcloud bugs (groups and shares, #8428, #7499)
The virtual host works (only tested on internal network using a server alias)

6 Likes

Sorry @greavette, but I couldn’t get to reproduce it, I’ve some problem with ad installation on my virtual machine. I’ve tried it binding NS to another ad domain and everythings worked.

Which logs have you seen ?
You can check various logs:

  • nextcloud /var/lib/nethserver/nextcloud/nextcloud.log
  • httpd
  • ldap

Ldap is alive ?
Have you ever customized ldap configuration manually ?

FYI, Nextcloud released Nextcloud 13.0.1

4 Likes

… and it seems to have many improvements https://nextcloud.com/changelog/#latest13 !!! :+1:
Hope to have v13 released quickly :wink:

2 Likes

v13.0.0 has been skipped, now 13.0.1 is on pull request

4 Likes

Everything is ready on testing.

If we don’t find any issue, we will release it tomorrow.

2 Likes

Looks great :slight_smile: