Nextcloud 13 - Call for QA!

testing

(Markus Neuberger) #21

Tested it and it worked like a charm! :+1::clap: Great work!

Test on VMWare VM

  1. clean install

  2. no warnings or errors in admin panel

  3. local ldap and ad users can login

  4. bookmarks app works

Little problem but maybe not nextcloud related:

I wanted to read /var/log/messages and got:

Mar  6 13:24:10 testserver rsyslogd: [origin software="rsyslogd" swVersion="8.24.0" x-pid="4360" x-info="http://www.rsyslog.com"] rsyslogd was HUPed

Restarting rsyslog solved it.

Test on VPS

  1. update on VPS

  2. no warnings or errors in admin panel

  3. local ldap users can login

  4. bookmarks and onlyoffice app work


(Ralf Jeckel) #22

You did nethforge-testing not nethserver-testing?


(Markus Neuberger) #23

Please execute the following, it should update nethserver-nextcloud…

yum install nethserver-nextcloud --enablerepo=nethserver-testing


(Michael Träumner) #24

You’re right, thanks a lot.

I did:

yum remove nethserver-nextcloud

and after that:

yum install nethserver-nextcloud --enablerepo=nethserver-testing

Thank you too. Know it works without any problems.


(Ralf Jeckel) #25

Error came from wrong gateway setting in NS installation.

Now everything is good:

image

  1. test clean install and update from 12.0.5 => test passed o.k.
  2. verify that admin settings has no warnings or errors => test passed o.k.
  3. verify login as admin and normal user with ad => test passed o.k. (ldap not tested)
  4. verify one nextcloud app installation at least => installed calendar: test passed o.k.

Tested on proxmox VM, clean install from iso 7.4.1708, installed NC 12, updated to NC 13 via testing repo.

Great job @alep . Thanks a lot for your work. :+1: :ok_hand:


(Markus Neuberger) #26

I tested it on a fresh VM and when installing without Nethserver-testing you get the white/blank screen in firefox. One has to install the nethserver-nextcloud testing package to make Nextcloud 13 work.
@davidep , is this a problem? It may be the same when installing from software center like @flatspin , the nethserver-nextcloud testing package has to be pushed to nethserver-updates I think.


(Marcin) #27

Hi, on fresh install from web-gui also have problem (red yum cache problem) and 500 error when entering nextcloud.
Is it a bug that nextcloud 13 is in updates if it needs nethserver-nextcloud testing?
Updating from 12.0.5 to 13 went ok but seems to have same problem as before - AD groups are not respected.
If check “share only in groups” every user in autocompletion is listed, if i turnoff this it not shows any user but i still can share with any user AD ldap and local. Is there any fix for this? Thanks in advance.


White screen or internal server error 500 after Nextcloud 13 install
#28

or maybe is better to move nextcloud13 package in nethserver-testing instead of nethserver-updates?


(Marcin) #29

I thought Nextcloud 13 is already tested so is in nethserver-updates. If is not it’s a bad practice to put it there, i think. How we can avoid this is the future?
Nethserver is a great piece of software but i had few problems after update that i thing shouldn’t happen on a server. Is it possible or maybe needed by users to make updates more restricted (more safe)? Cheers and thanks for Your support.


(Ralf Jeckel) #30

definitely yes. nethserver-updates is enabled by default, so with an install of NC through softwarecenter you get a broken NC13 by default!
Not easy to solve for a newcomer. Not good for reputation of NS.


(Michael Träumner) #31

@dev_team Could you have a look for it.


(Giacomo Sanchietti) #32

Holy s***t! I bet it’s my fault, but I don’t have access right now to fix the problem.

@flatspin, you can fix your installation by installing everything with testing repository enabled.

Sorry, I will fix ASAP :frowning:


(Ralf Jeckel) #33

Don’t wory. No problem for me so far. I installed from cmd with updates-repo disabled and got NC 12. Update with testing-repo worked perfect. So I have a working installation NC 13. Also found a solution for cert issue with onlyoffice in NC 13.
Everything is fine for me. :wink:


(Giacomo Sanchietti) #34

Of course the nextcloud package should have been published in nethserver-testing.
I used the wrong command this morning, the problem should now be fixed.

Mirrors will be in sync in few hours.


White screen or internal server error 500 after Nextcloud 13 install
White screen or internal server error 500 after Nextcloud 13 install
(Marc) #35

3 posts were split to a new topic: Nextcloud cryptic usernames


(sb) #36

And when will NC13 pass from testing to updates repo?

Thanks in advance


(Alessio Fattorini) #37

When it’s ready I guess and it’s tested enough.
Would you mind helping us? So we can shorten this period


(Giacomo Sanchietti) #38

Upgraded our production server, no problems so far.


(Alessio Fattorini) #39

NexCloud talk app looks amazing! Very easy and with good performance. They did an amazing job
The WebUI looks very nice and fast


(Alessandro Polidori) #40

remember to enable the app

and to enable this option

to see the user list

image