New problem with OnlyOffice

NethServer Version: 7.9
Module: Nextcloud

In these days I have installed an Enterprise nethserver and with the Markuz procedure the onlyoffice, as already many other times.
In the laboratory, to test, I installed and used the IP of the Lan with the commands to accept self-signed certificates and precisely the IP of the LAN.
In the past this procedure has always worked, now it doesn’t.
So, I did the same installation on a nethserver comunity installed some time ago and the procedure worked. At first glance the difference between the two machines is the version of nextcloud, this Saturday.
Today I tried again and even the old machine no longer works, so I don’t think it’s a nextcloud version problem. On both machines if I browse https://myiplan:8082, I can see the document server page correctly.
When I go in Nextcloud/config/Onlyoffice and push SAVE button in both servers, this is the result:

Where, do i start troubleshooting?

Posting english screenshots :wink:

1 Like

unfortunately I am not able to replicate the page in English.
I changed the language of the nethserver.
I changed the language to the nextcloud admin.
But I always see the onlyoffice configuration page in Italian …
Anyway I can attach the error log and that is in English …

|Error|onlyoffice|Exception: An error has occurred in the document service: Invalid token

  1. /usr/share/nextcloud/apps/onlyoffice/lib/documentservice.php - line 302:OCA\Onlyoffice\DocumentService->ProcessCommandServResponceError(6)
  2. /usr/share/nextcloud/apps/onlyoffice/lib/documentservice.php - line 408:OCA\Onlyoffice\DocumentService->CommandRequest(“version”)
  3. /usr/share/nextcloud/apps/onlyoffice/controller/settingscontroller.php - line 172:OCA\Onlyoffice\DocumentService->checkDocServiceUrl(OC\URLGenerator {}, OCA\Onlyoffice\Crypt {})
  4. /usr/share/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 218:OCA\Onlyoffice\Controller\SettingsController->SaveAddress(“”, “”, “”, true, “”, false)
  5. /usr/share/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 127:OC\AppFramework\Http\Dispatcher->executeController(OCA\Onlyoffi … {}, “saveAddress”)
  6. /usr/share/nextcloud/lib/private/AppFramework/App.php - line 157:OC\AppFramework\Http\Dispatcher->dispatch(OCA\Onlyoffi … {}, “saveAddress”)
  7. /usr/share/nextcloud/lib/private/Route/Router.php - line 302:OC\AppFramework\App::main(“SettingsController”, “saveAddress”, OC\AppFramew … {}, { _route: "o … "})
  8. /usr/share/nextcloud/lib/base.php - line 993:OC\Route\Router->match("/apps/onlyo … s")
  9. /usr/share/nextcloud/index.php - line 37:OC::handleRequest()|
    | — | — |

Please check if the token is correct:

Now all OK.

In the past I have installed many times from your how-to and the onlyoffice connector installed itself automatically with the password already entered.

  1. Why, when I did the installation from your HowTo, the ONLYOFFICE connector did not install itself automatically as it always did in the past.

I had to instal manualy the connector and the password field was blank.
Is there any known reason?

Maybe you installed Onlyoffice before Nextcloud?

Onlyoffice checks if Nextcloud is installed and sets up the connector.

If you installed Nextcloud afterwards you need to run

signal-event nethserver-onlyoffice-update

to setup the connector.

No, I’m sure.

  1. I install nethserver
  2. I install nextcloud
  3. I install OnlyOfice.
    I’ve always done that.
    I do other tests to see if it was a case and then I tell you.
1 Like

I could reproduce the issue.
With the recent Nextcloud version one can just type occ instead of the long version sudo -u apache /opt/rh/rh-php73/root/usr/bin/php -d memory_limit=512M /usr/share/nextcloud/occ
For the long version to work it would need --define apc.enable_cli=1 but just using occ is the right method.

In /etc/e-smith/events/actions/nethserver-onlyoffice-conf you may replace the 4 occ lines

sudo -u apache /opt/rh/rh-php73/root/usr/bin/php -d memory_limit=512M /usr/share/nextcloud/occ ...


occ ...

I’m going to update the module, thanks for pointing out.


Module updated. Update with

yum update nethserver-onlyoffice