New GLPI 10 version?

GLPI seems to be upping their game with an upcoming version of the same system, with modernized improvements.

Here are some details of whats coming up, seems to be very nifty

1 Like

no time yet but do you have a migration path between 9 to 10 ?

i do not have a migration path, since i don’t believe i am skilled enough to target that. But i would be open to assist if need arises whoever is approaching the same.

1 Like

been playing around with it abit


they have really reworked that interface.

2 Likes

A Release Candidate for the GLPI V 10 seems to be available.

maybe this is the time to test deployment, as well as Migration from previous version, in readiness to the actual release?

2 Likes

We Have Release Candidate 2 Available for testing:
Release 10.0.0-rc2 · glpi-project/glpi (github.com)

2 Likes

Release Candidate 3 is now Available

1 Like

It is Official, GLPI10 is expected to be released on 20th April

At Teclib´ we are happy to announce that we are expecting the release of GLPI 10 on the 20th of April . We have received many questions related to migration from older versions of GLPI/compatibility of plugins and published a dedicated video with answers.

Watch it on Youtube or read the transcription in our blog post.

Click to read: https://glpi-project.org/migration-to-glpi-10-faq/

1 Like

Still no time :slight_smile:

i understand, you guys are busy working to push out NS8, maybe someone more experienced in the community could help take up the update to the module.

otherwise, i can also take a look at the module, and see if its possible for me to push an update.

One thing i am sure, i might be able to update the module to new version, but, for a fresh install, not upgrade, still @Shane_Treweek has been working alot on glpi together with flyvemdm, maybe could join in.

1 Like

sounds good

https://glpi-install.readthedocs.io/en/latest/prerequisites.html

database should be OK, PHP NOK >= 7.4

why is this the case, could we not upgrade the current version to use php7.4 since it supports?

then when 10 is available, up its an inplace upgrade.

what php version does the current glpi-latest use

the big change of glpi10 is the agent (fork of fusion inventory)
https://glpi-agent.readthedocs.io/en/latest/

read Above…

glpi-latest iirc uses php73 so 7.3 should be possible to get glpiqp working by setting the environment variables switch I think it’s how I got fusion inventory to use mariadb that is installed with glpi-latest

php7.3

ideally we should make a new rpm with php81, actually it exists a rpm with php80 but rpm need to be updated manually

https://rpms.remirepo.net/enterprise/7/safe/x86_64/repoview/letter_p.group.html

Maximum php supported version for glpi 9.5.x is 8.0 so we cant do 8.1.
and if we have the new rpm with php 8.0,
we can update the current glpi version to php 8.0
then the new update version, would be to work on the database migration, and we will have a new version, hopefully stress free.