NetxCloud12, Docker, SSL, Collabora > Last Step Error?


(Bastiaan de Jonge) #1

I have upgraded the base php to v. 5.6.30, no problems found yet :slight_smile:

But now on another test server i ran a fresh install of nethserver + nextcloud 12 from software-center
"Still i can not user Collabora , just can’t open the document, even when docker + collabora/code is running."

Installed nextcloud and upgraded to v 12, Seems to work fine…
Installed a subdomain with self signed SSL Certificate, Okay…
Installed Coloboration, (Itegrated office on nextcloud) looks great but stuck on last point.
I got this error at the moment when i click an office document.

Anyone a sollution ?
When everything works i’ll publish my “how to” list here …

Greetings,
Bastiaan de Jonge
Xonline / Technorama LLP


Collabora Online
(Stéphane de Labrusse) #2

Just my opinion here, even if I love to see a willingness like yours, propose to upgrade php is not safe. You should use the software collection of redhat/remi, the rpm for ns7 https://github.com/NethServer/nethserver-rh-php56-php-fpm or even my rpm to install php{56;70,71}-php* (nethserver-php-scl)

like this you can have several versions of php, without to remove/upgrade the default one.


(Bastiaan de Jonge) #3

This is how i updated to php 5.6.3, until now my development server runs fine, i have not found any issues.

php -v
   PHP 5.4.16 (cli) (built: Nov  6 2016 00:29:02)
yum install http://rpms.remirepo.net/enterprise/remi-release-7.rpm
yum install yum-utils
yum-config-manager --enable remi-php56
yum update
php -v
   PHP 5.6.30 (cli) (built: Jan 19 2017 07:57:06)
```

(Bastiaan de Jonge) #4

Edit /usr/share/nextcloud/config/config.php and add: 'debug' => true,

Now a lot more is shown, anyone knows what is going wrong here ?

--------------------------------------------------------------------------------------------------------------------------------------
Internal Server Error
The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.

Technical details
Remote Address: 62.207.25.205
Request ID: WVpzwm0up0UIXAYSHt1o7QAAAAQ
Type: GuzzleHttp\Exception\ClientException
Code: 404
Message: Client error response [url] https://office.xonlineserver.nl/hosting/discovery [status code] 404 [reason phrase] Not Found
File: /usr/share/nextcloud/3rdparty/guzzlehttp/guzzle/src/Exception/RequestException.php
Line: 89

Trace
#0 /usr/share/nextcloud/3rdparty/guzzlehttp/guzzle/src/Subscriber/HttpError.php(33): GuzzleHttp\Exception\RequestException::create(Object(GuzzleHttp\Message\Request), Object(GuzzleHttp\Message\Response))
#1 /usr/share/nextcloud/3rdparty/guzzlehttp/guzzle/src/Event/Emitter.php(108): GuzzleHttp\Subscriber\HttpError->onComplete(Object(GuzzleHttp\Event\CompleteEvent), 'complete')
#2 /usr/share/nextcloud/3rdparty/guzzlehttp/guzzle/src/RequestFsm.php(91): GuzzleHttp\Event\Emitter->emit('complete', Object(GuzzleHttp\Event\CompleteEvent))
#3 /usr/share/nextcloud/3rdparty/guzzlehttp/guzzle/src/RequestFsm.php(132): GuzzleHttp\RequestFsm->__invoke(Object(GuzzleHttp\Transaction))
#4 /usr/share/nextcloud/3rdparty/react/promise/src/FulfilledPromise.php(25): GuzzleHttp\RequestFsm->GuzzleHttp\{closure}(Array)
#5 /usr/share/nextcloud/3rdparty/guzzlehttp/ringphp/src/Future/CompletedFutureValue.php(55): React\Promise\FulfilledPromise->then(Object(Closure), NULL, NULL)
#6 /usr/share/nextcloud/3rdparty/guzzlehttp/guzzle/src/Message/FutureResponse.php(43): GuzzleHttp\Ring\Future\CompletedFutureValue->then(Object(Closure), NULL, NULL)
#7 /usr/share/nextcloud/3rdparty/guzzlehttp/guzzle/src/RequestFsm.php(135): GuzzleHttp\Message\FutureResponse::proxy(Object(GuzzleHttp\Ring\Future\CompletedFutureArray), Object(Closure))
#8 /usr/share/nextcloud/3rdparty/guzzlehttp/guzzle/src/Client.php(165): GuzzleHttp\RequestFsm->__invoke(Object(GuzzleHttp\Transaction))
#9 /usr/share/nextcloud/3rdparty/guzzlehttp/guzzle/src/Client.php(125): GuzzleHttp\Client->send(Object(GuzzleHttp\Message\Request))
#10 /usr/share/nextcloud/lib/private/Http/Client/Client.php(138): GuzzleHttp\Client->get('https://office....', Array)
#11 /usr/share/nextcloud/apps/richdocuments/lib/WOPI/DiscoveryManager.php(84): OC\Http\Client\Client->get('https://office....')
#12 /usr/share/nextcloud/apps/richdocuments/lib/WOPI/Parser.php(41): OCA\Richdocuments\WOPI\DiscoveryManager->get()
#13 /usr/share/nextcloud/apps/richdocuments/lib/TokenManager.php(117): OCA\Richdocuments\WOPI\Parser->getUrlSrc('application/vnd...')
#14 /usr/share/nextcloud/apps/richdocuments/lib/Controller/DocumentController.php(108): OCA\Richdocuments\TokenManager->getToken(230)
#15 [internal function]: OCA\Richdocuments\Controller\DocumentController->index('230')
#16 /usr/share/nextcloud/lib/private/AppFramework/Http/Dispatcher.php(160): call_user_func_array(Array, Array)
#17 /usr/share/nextcloud/lib/private/AppFramework/Http/Dispatcher.php(90): OC\AppFramework\Http\Dispatcher->executeController(Object(OCA\Richdocuments\Controller\DocumentController), 'index')
#18 /usr/share/nextcloud/lib/private/AppFramework/App.php(114): OC\AppFramework\Http\Dispatcher->dispatch(Object(OCA\Richdocuments\Controller\DocumentController), 'index')
#19 /usr/share/nextcloud/lib/private/AppFramework/Routing/RouteActionHandler.php(47): OC\AppFramework\App::main('DocumentControl...', 'index', Object(OC\AppFramework\DependencyInjection\DIContainer), Array)
#20 [internal function]: OC\AppFramework\Routing\RouteActionHandler->__invoke(Array)
#21 /usr/share/nextcloud/lib/private/Route/Router.php(299): call_user_func(Object(OC\AppFramework\Routing\RouteActionHandler), Array)
#22 /usr/share/nextcloud/lib/base.php(1000): OC\Route\Router->match('/apps/richdocum...')
#23 /usr/share/nextcloud/index.php(40): OC::handleRequest()
#24 {main}
--------------------------------------------------------------------------------------------------------------------------------------

Also under the Admin section some php settings seem to be not perfectly in line with Nextclouds wishes.

[quote]
Security & setup warnings

It’s important for the security and performance of your instance that everything is configured correctly. To help you with that we are doing some automatic checks. Please see the Tips & Ticks section and the documentation for more information.

The “Strict-Transport-Security” HTTP header is not configured to at least “15552000” seconds. For enhanced security we recommend enabling HSTS as described in our security tips.
No memory cache has been configured. To enhance your performance please configure a memcache if available. Further information can be found in our documentation.
The PHP Opcache is not properly configured. For better performance we recommend :arrow_upper_right: to use following settings in the php.ini:
opcache.enable=1
opcache.enable_cli=1
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=10000
opcache.memory_consumption=128
opcache.save_comments=1
opcache.revalidate_freq=1
Please double check the installation guides :arrow_upper_right:, and check for any errors or warnings in the log.[/quote]


(Bastiaan de Jonge) #5

I see, NextCloud 12 is now available from the webinterface software-center, it installs fine, but still i can not
use collabora online on it, see the error messages i posted… I have not found a sollution (yet). Anyone ?


(Marc) #6

For some of those warnings take a look at this thread:


(Bastiaan de Jonge) #7

No .htaccess.rpmnew of anything like that on my current setup

I reinstalled Nethserver, so a fresh install, i installed the following:

I setup office.domain.xx and cloud.domain.xx in my dns, and waited for the dns to resolve

I used the webinterface to configure a requested ssl certificate for these subdomains,

Then i installed

I can login to office.domain.xx/nextcloud with admin / Nethesis,1234 ( The default password )

I setup collabora online under + Apps in Nextcloud

I entered my ssl url ( https://office.domain.xx ) under the Admin / Collabora Online Section

I added [ 1 => ‘office.domain.xx’, ] to /usr/share/nextcloud/config/config.php ( local ip, and some more … )

I also added [ ‘debug’ => true ] to /usr/share/nextcloud/config/config.php ( to see debug info on errors ).

I can create new office documents now.

but i still cannot open / edit them.<img

I installed docker and the docker image collabora_nextcloud
When i run docker ps i see it is running, so i think i done this correctly

on https://office.domain.xx:9980 i get a small message: ok

As you can see, it is not secure, could this be (part of) the issue ?
Anyone…


(other names Tedd77/Giorgio09) #8

@Xonline
i allow myself to intervene in what concerns collabora.
Collabora is unfortunately not the package you need to do online office editing.
Please have a look at this post.

It is as simple as 123 to install, all you need is a separate server (vm machine) independent of Nethserver
I am using it with 2 different Nethserver servers (one ONLYOFFICE instance)

The advantage over collabora , when you create an online document (say word) the collabora will create it with extension ODT then you cannot open it elsewhere.
Where with ONLYOFFICE files created online have same Microsoft office extension and they are 100% office 2010
example : I created a powerpoint with office 2010 and was able to see it with Microsoft powerpoint 2010 as well as with onlyoffice . Same format no changes.

Same file when opened with Collabora it changed the formatting of the fonts as well as some graphics.Therefore it changed the look of my presentation.

Ah it is much facter in loading than collabora
The only advantage is the 20 sessions limitation on the community version. for me it was very sufficient and could serve a community of 100 users by applying the 5/1 sharing which is very fair normally it is 10/1.


(Bastiaan de Jonge) #9

Nice idea, i will make some time to try out the possibilities, but i see there is no Dutch translation for OnlyOffice yet, ( and i don’t have time to translate one ), also i have seen the prices at their website, starting from $600 a month, i was shocked! I doubt if the 20 sessions limitation is a permanent thing, maybe they change this in the next version… i would not like to take the risk when renting this server to a 100 users company. The fact i need to install an extra VPS for only 20 instances won’t hold very long when renting multiple VPS Servers to different customers, and an extra VPS for Each customer won’t fit in the low price level i charge to my customers.
Collabora will get better during time, at this moment their offers look more friendly to me.
Anyway i will check out OnlyOffice later on this week, so i get to know what i am talking about.

Thanks for your input anyway!,
Keep up the good work…


(other names Tedd77/Giorgio09) #10

@Xonline

I don’t know about dutch , mine has French and English without issues.
I hope the 20 sessions limitation will become 40 but not less nor at a fee.

Just shared my experience and good luck.


(Giacomo Sanchietti) #11

It seems the reported URL doesn’t work, but I have no idea what it is or should be :wink:


(Marc) #12

I think is used as the WOPI discovery URL set in the reverse proxy configuration.