Network shares not accessable from VM

The problem:
MS Windows 10 virtual machine cannot browse for network shares on the server.

The Hardware:
PC = HP Z200 Workstation.
NICs = Intel ® 82578DM Gigabit Network Connection or Intel ® Gigabit CT Desktop Adaptor.

Virtualization platform = VirtualBox 6.0 (Version 6.0.6r128413) and at least one previous version.
Host OS = Windows 10 Enterprise 2016 LTSB Version 1607 (OS Build 14393.2848).
VM = Windows 10 Enterprise LTSC Version 1809 (OS Build 17763.107)
Server = Linux NethServer release 7.6.1810 (final) Kernel release 3.10.0-957.10.1.el7.x86_64

The following points are noted:

  1. I have been using this general setup for some time with no issues.
  2. When the problem happened I made sure all updates were applied (MS WIndows host, MS WIndows VM and Nethserver server). VirtualBox was upgraded to the latest version.
  3. I can ping from the VM to the server.
  4. I can join the VM to the domain.
  5. In the GUI, using \ \Nethserver\software does not work whereas it does from the host (applies to any other share as well).
  6. Using \ \\software does not work whereas it does from the host.
  7. Net use z: \ \Nethserver\software does not work.
  8. Both host LAN cards have been used to no avail.
  9. I have reinstalled the VM from the ISO.
  10. I have a classroom of HP Z200 PCs – the problem is on all of them. Please note though that the W10 hosts OSs are fine – accessing shares is good.
  11. However I have just tested an older PC (Core 2 Duo running Windows 8.1) and using the host machine (no VM) it suffers from the same problem.

Any ideas would be greatly appreciated!
Thanks in anticipation.


I’m not a Windows user, but I saw some posts about be specific of the SMB protocol version?


You could try to activate the smb1 protocol at the clients again.

Maybe the official Microsoft page should suit better…
I suggest to save powershell scripts into a handy place for get the client on track.

smbv1 should not be enabled, in my opinion. Quite old and unsafe protocol


Thank you everyone for your responses. I have been busy on other things but will investigate what you have said and respond within a day or so.

I have disabled SMBv1 and as a long shot disabled IPv6. No change. I am trying a different version of W10 to see if it does the same.

Here is what I have found -

  1. I have installed MS Windows 10 Version 1607 (OS Build 14393.0) Enterprise Version 2016 LTSB. There are no problems with this version.
  2. Version 1809 (OS Build 17763.379) Enterprise Version 2018 LTSC will not browse the network to //Nethserver. Yet as said above I can join the domain.

Both installed into VirtualBox.
The issue appears to be communication between Nethserver and the later version of MS Windows.

So I am making progress - I have added into LTSC SMBv1 which is not enabled by default and I can now see the GUI but not connect to it.

All the material I can find on-line tends to suggest that adding the SMBv1.0 Protocol back in either using Powershell or from Windows Features is all that is needed to get back to normal… not working for me unfortunately.

You can try to set smb protocol version to smb2 or smb3 on your nethserver.

create a new template with the editor you like, I use nano:

nano /etc/e-smith/templates-custom/etc/samba/smb.conf/20smbversion

and write

protocol = SMB3


protocol = SMB2

at this file. Try which one works for you. After creating the file with the protocol-version you have to expand the template with

expand-template /etc/samba/smb.conf

For more details about working with templates have a look at the documentation:

At the following link you can find some information about the tip with the protocol

1 Like

Thanks for this Michael. I have been to busy to take tis on board but will do in due course. John.

1 Like