Nethservers can't reach each other through IPsec Tunnel


In my setup, I have two Nethservers (old v6.8 and new v7final on different rootservers), connected to the Internet. Between them is a VPN Tunnel (ipsec), build by the two Nethservers. All clients have the Nethservers (depending on site) as their default gateway and can communicate through the VPN Tunnel, but if I do a trace on the new Nethserver to the old one, it is not using the IPsec tunnel. How do I configure this?


Calling in a few people that have worked with IPsec
@harry @EddieA @ssabbath @bwdjames @buddha @Cloud21 @filippo_carletti @davide_marini
Anyone else with insights please jump in

Have you checked your routing table and zones are correctly setup to use the vpn connection?


yes, I checked it.
The other Nethserver was in a range that was not in the routing table (but in the “remote networks” in the IPSec-Config on the Nethserver GUI). I added it using the Nethserver or the other Nethserver as a Gateway but it didn’t worked.
Finally I “solved” it by connecting externally and bypassing the tunnel that way.

Nope, no EXP on IPsec here, only pptp and OpenVPN :frowning: